p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de passport-wsfed-saml2

Vulnérabilité publiée pour passport-wsfed-saml2 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2025-46573

    Élevée · CVSS 8.6EPSS 0,37%Correctif disponible

    passport-wsfed-saml2 Has SAML Authentication Bypass via Attribute Smuggling

    passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by tampering with a valid SAML response. This can be done by adding attributes to the response. Users are affected specifically when the service provider is using `passport-wsfed-saml2` and a valid SAML Response signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.

    • Mettez à jour vers 4.6.4
    Publication Mise à jour
  2. CVE-2025-46572

    Critique · CVSS 9.3EPSS 0,42%Correctif disponible

    passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping

    passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP. Users are affected specifically when the service provider is using passport-wsfed-saml2 and a valid SAML document signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.

    • Mettez à jour vers 4.6.4
    Publication Mise à jour
  3. GHSA-5wrg-8fxp-cx9r

    Non évaluéeCorrectif disponible

    passport-wsfed-saml2 Signature Bypass vulnerability

    ## Information Please note that this is not a new disclosure, and is previously reported in our [SECURITY-NOTICE.md](https://github.com/auth0/passport-wsfed-saml2/commit/520b9fc0bb4249ce83bec47e30153419f086ab70 ) which we removed in favor of github advisory. # Overview A vulnerability was found in the validation of a SAML signature. The validation doesn't ensure that the "Signature" tag is at the proper location inside an "Assertion" tag. This leads to a signature relocation attack where the attacker can corrupt one field of data while maintaining the signature valid. This could allow an authenticated attacker to "remove" one group from th

    • Mettez à jour vers 3.0.10
    Publication Mise à jour
  4. CVE-2022-23505

    Moyenne · CVSS 5.3EPSS 0,8%Correctif disponible

    Passport-wsfed-saml2 vulnerable to Authentication Bypass for WSFed authentication

    Passport-wsfed-saml2 is a ws-federation protocol and SAML2 tokens authentication provider for Passport. In versions prior to 4.6.3, a remote attacker may be able to bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. This issue is patched in version 4.6.3. Use of SAML2 authentication instead of WSFed is a workaround.

    • Mettez à jour vers 4.6.3
    Publication Mise à jour
  5. CVE-2017-16897

    Élevée · CVSS 8.1EPSS 1,38%Correctif disponible

    CVE-2017-16897

    A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).

    • Mettez à jour vers 3.0.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →