p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de postcss

Vulnérabilité publiée pour postcss au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 7

  1. CVE-2026-73646

    Élevée · CVSS 7.5EPSS 0,53%Correctif disponible

    PostCSS: Path Traversal in Previous Source Map Auto-Loading (sourceMappingURL) leads to Arbitrary .map File Disclosure

    PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. Prior to 8.5.18, lib/previous-map.js loadMap() passes attacker-controlled sourceMappingURL values to join(dirname(opts.from), annotation), and loadFile() permits traversed or absolute .map paths, allowing untrusted CSS processed without map: false to disclose sourcesContent from arbitrary reachable .map files through result.map. This issue is fixed in version 8.5.18.

    • Mettez à jour vers 8.5.18
    Publication Mise à jour
  2. CVE-2026-69153

    Moyenne · CVSS 6.3EPSS 0,45%Correctif disponible

    PostCSS: incomplete fix of CVE-2026-45623 — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset

    PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. Prior to 8.5.19, if from is unset, an attacker can cause PreviousMap.loadFile() to read an unintended source-map file by supplying an absolute or directory-traversal sourceMappingURL. The resulting map’s sources and sourcesContent may then be exposed to the application. This issue is fixed in version 8.5.19.

    • Mettez à jour vers 8.5.23
    Publication Mise à jour
  3. CVE-2026-45623

    Élevée · CVSS 7.5EPSS 0,61%Correctif disponible

    PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments

    PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. In versions 8.5.11 and prior, the PreviousMap parses the /*# sourceMappingURL=PATH */ comment from any CSS string passed to process() and dereferences PATH against the local filesystem with no scheme, allowlist, or traversal check. An attacker who controls the CSS input can cause the host process to read any file readable by Node and leak the first ~10 bytes of its content through the resulting JSON.parse SyntaxError message. The bug also yields a precise file-existence oracle and a controllable-read primitive t

    • Mettez à jour vers 8.5.12
    Publication Mise à jour
  4. CVE-2026-41305

    Moyenne · CVSS 6.1EPSS 0,21%Correctif disponible

    PostCSS has XSS via Unescaped </style> in its CSS Stringify Output

    PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. Versions prior to 8.5.10 do not escape `</style>` sequences when stringifying CSS ASTs. When user-submitted CSS is parsed and re-stringified for embedding in HTML `<style>` tags, `</style>` in CSS values breaks out of the style context, enabling XSS. Version 8.5.10 fixes the issue.

    • Mettez à jour vers 8.5.10
    Publication Mise à jour
  5. CVE-2023-44270

    Moyenne · CVSS 5.3EPSS 0,97%Correctif disponible

    CVE-2023-44270

    An issue was discovered in PostCSS before 8.4.31. The vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being included in a comment.

    • Mettez à jour vers 8.4.31
    Publication Mise à jour
  6. CVE-2021-23382

    Moyenne · CVSS 5.3EPSS 2,56%Correctif disponible

    Regular Expression Denial of Service (ReDoS)

    The package postcss before 8.2.13 are vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js. The vulnerable regexes are caused mainly by the sub-pattern \/\*\s* sourceMappingURL=(.*).

    • Mettez à jour vers 7.0.36
    • Mettez à jour vers 8.2.13
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →