p PatchFirst

PatchFirst · Vulnérabilités récentes

ci4-cms-erp/ci4ms 0.31.9.0 : vulnérabilités connues

Vulnérabilité connue concernant ci4-cms-erp/ci4ms 0.31.9.0 : 1. Comparez les versions corrigées ci-dessous avec celle que vous utilisez.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilité : 1

  1. CVE-2026-34989

    Critique · CVSS 9.4EPSS 0,3%Correctif disponible

    CI4MS affected by Profile & User Management Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS

    CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 31.0.0.0, the application fails to properly sanitize user-controlled input when users update their profile name (e.g., full name / username). An attacker can inject a malicious JavaScript payload into their profile name, which is then stored server-side. This stored payload is later rendered unsafely in multiple application views without proper output encoding, leading to stored cross-site scripting (XSS). This vulnerability is fixed in 31.0.0.0.

    • Mettez à jour vers 31.0.0.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →