p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de illuminate/cookie

Vulnérabilité publiée pour illuminate/cookie au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. GHSA-2867-6rrm-38gr

    Non évaluéeCorrectif disponible

    Laravel Cookie serialization vulnerability

    Laravel 5.6.30 is a security release of Laravel and is recommended as an immediate upgrade for all users. Laravel 5.6.30 also contains a breaking change to cookie encryption and serialization logic. Refer to [laravel advisory](https://laravel.com/docs/5.6/upgrade#upgrade-5.6.30) for more details and read the notes carefully when upgrading your application.

    • Mettez à jour vers 5.6.30
    Publication Mise à jour
  2. GHSA-2ffv-r4r9-r8xr

    Non évaluéeCorrectif disponible

    Laravel RCE vulnerability in "cookie" session driver

    Application's using the "cookie" session driver were the primary applications affected by this vulnerability. Since we have not yet released a security release for the Laravel 5.5 version of the framework, we recommend that all applications running Laravel 5.5 and earlier do not use the "cookie" session driver in their production deployments. Regarding the vulnerability, applications using the "cookie" session driver that were also exposing an encryption oracle via their application were vulnerable to remote code execution. An encryption oracle is a mechanism where arbitrary user input is encrypted and the encrypted string is later displayed

    • Mettez à jour vers 6.18.31
    • Mettez à jour vers 7.22.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →