p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de islandora/crayfish

Vulnérabilité publiée pour islandora/crayfish au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2025-25286

    Critique · CVSS 9.8EPSS 1,02%Correctif disponible

    Crayfish allows Remote Code Execution via Homarus Authorization header

    Crayfish is a collection of Islandora 8 microservices, one of which, Homarus, provides FFmpeg as a microservice. Prior to Crayfish version 4.1.0, remote code execution may be possible in web-accessible installations of Homarus in certain configurations. The issue has been patched in `islandora/crayfish:4.1.0`. Some workarounds are available. The exploit requires making a request against the Homarus's `/convert` endpoint; therefore, the ability to exploit is much reduced if the microservice is not directly accessible from the Internet, so: Prevent general access from the Internet from hitting Homarus. Alternatively or additionally, configure a

    • Mettez à jour vers 4.1.0
    Publication Mise à jour
  2. GHSA-c2p2-hgjg-9r3f

    Critique · CVSS 9.5Aucun correctif publié

    Crayfish Allows Remote Code Execution via hypercube X-Islandora-Args Header

    ### Impact _What kind of vulnerability is it? Who is impacted?_ Remote code execution is possible in web-accessible installations of hypercube. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Not yet, though no patch is neccessary if your installation of the microservices is behind a firewall. See below. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ The exploit requires making a request against Hypercube's endpoints; therefore, the ability to make use of the exploit is much reduced if the microservice is not directly accessible from the Internet, s

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →