p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de moodle/moodle · Page n° 10

Vulnérabilité publiée pour moodle/moodle au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 437

  1. CVE-2021-43560

    Moyenne · CVSS 5.3EPSS 1,13%Correctif disponible

    CVE-2021-43560

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.

    • Mettez à jour vers 3.10.8
    • Mettez à jour vers 3.11.4
    • Mettez à jour vers 3.9.11
    Publication Mise à jour
  2. CVE-2021-43559

    Élevée · CVSS 8.8EPSS 0,62%Correctif disponible

    CVE-2021-43559

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. The "delete related badge" functionality did not include the necessary token check to prevent a CSRF risk.

    • Mettez à jour vers 3.10.8
    • Mettez à jour vers 3.11.4
    • Mettez à jour vers 3.9.11
    Publication Mise à jour
  3. CVE-2021-43558

    Moyenne · CVSS 6.1EPSS 0,87%Correctif disponible

    CVE-2021-43558

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.

    • Mettez à jour vers 3.10.8
    • Mettez à jour vers 3.11.4
    • Mettez à jour vers 3.9.11
    Publication Mise à jour
  4. CVE-2021-21809

    Élevée · CVSS 8.2EPSS 24,17%Code d’exploitation publicAucun correctif publié

    CVE-2021-21809

    A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.

    Publication Mise à jour
  5. CVE-2021-20283

    Moyenne · CVSS 4.3EPSS 1,11%Correctif disponible

    CVE-2021-20283

    The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Mettez à jour vers 3.10.2
    • Mettez à jour vers 3.5.17
    • Mettez à jour vers 3.8.8
    • Mettez à jour vers 3.9.5
    Publication Mise à jour
  6. CVE-2021-20282

    Moyenne · CVSS 5.3EPSS 1,32%Correctif disponible

    CVE-2021-20282

    When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Mettez à jour vers 3.10.2
    • Mettez à jour vers 3.5.17
    • Mettez à jour vers 3.8.8
    • Mettez à jour vers 3.9.5
    Publication Mise à jour
  7. CVE-2021-20281

    Moyenne · CVSS 5.3EPSS 1,36%Correctif disponible

    CVE-2021-20281

    It was possible for some users without permission to view other users' full names to do so via the online users block in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Mettez à jour vers 3.10.2
    • Mettez à jour vers 3.5.17
    • Mettez à jour vers 3.8.8
    • Mettez à jour vers 3.9.5
    Publication Mise à jour
  8. CVE-2021-20185

    Moyenne · CVSS 5.3EPSS 1,39%Correctif disponible

    CVE-2021-20185

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

    • Mettez à jour vers 3.10.1
    • Mettez à jour vers 3.5.16
    • Mettez à jour vers 3.8.7
    • Mettez à jour vers 3.9.4
    Publication Mise à jour
  9. CVE-2021-20184

    Moyenne · CVSS 4.3EPSS 0,73%Correctif disponible

    CVE-2021-20184

    It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.

    • Mettez à jour vers 3.10.1
    • Mettez à jour vers 3.8.7
    • Mettez à jour vers 3.9.4
    Publication Mise à jour
  10. CVE-2021-20186

    Moyenne · CVSS 5.4EPSS 0,76%Correctif disponible

    CVE-2021-20186

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.

    • Mettez à jour vers 3.10.1
    • Mettez à jour vers 3.5.16
    • Mettez à jour vers 3.8.7
    • Mettez à jour vers 3.9.4
    Publication Mise à jour
  11. CVE-2021-20183

    Moyenne · CVSS 5.4EPSS 0,83%Correctif disponible

    CVE-2021-20183

    It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.

    • Mettez à jour vers 4.0.0-beta
    Publication Mise à jour
  12. CVE-2021-20187

    Élevée · CVSS 7.2EPSS 1,59%Correctif disponible

    CVE-2021-20187

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

    • Mettez à jour vers 3.10.1
    • Mettez à jour vers 3.5.16
    • Mettez à jour vers 3.8.7
    • Mettez à jour vers 3.9.4
    Publication Mise à jour
  13. CVE-2020-25627

    Moyenne · CVSS 6.1EPSS 3,72%Correctif disponible

    CVE-2020-25627

    The moodlenetprofile user profile field required extra sanitizing to prevent a stored XSS risk. This affects versions 3.9 to 3.9.1. Fixed in 3.9.2.

    • Mettez à jour vers 3.9.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →