p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de orchid/platform

Vulnérabilité publiée pour orchid/platform au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2024-51992

    Moyenne · CVSS 4.1EPSS 0,33%Correctif disponible

    Method Exposure Vulnerability in Modals in orchid/platform

    Orchid is a @laravel package that allows for rapid application development of back-office applications, admin/user panels, and dashboards. This vulnerability is a method exposure issue (CWE-749: Exposed Dangerous Method or Function) in the Orchid Platform’s asynchronous modal functionality, affecting users of Orchid Platform version 8 through 14.42.x. Attackers could exploit this vulnerability to call arbitrary methods within the `Screen` class, leading to potential brute force of database tables, validation checks against user credentials, and disclosure of the server’s real IP address. The issue has been patched in the latest release, versi

    • Mettez à jour vers 14.43.0
    Publication Mise à jour
  2. CVE-2023-36825

    Critique · CVSS 9.7EPSS 1,12%Correctif disponible

    Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution

    Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards. A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the `_state` query parameter, which can result in remote code execution. The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.

    • Mettez à jour vers 14.5.0
    Publication Mise à jour
  3. CVE-2020-15263

    Élevée · CVSS 8EPSS 0,75%Correctif disponible

    XSS in platform

    In platform before version 9.4.4, inline attributes are not properly escaped. If the data that came from users was not escaped, then an XSS vulnerability is possible. The issue was introduced in 9.0.0 and fixed in 9.4.4.

    • Mettez à jour vers 9.4.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →