p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de robrichards/xmlseclibs

Vulnérabilité publiée pour robrichards/xmlseclibs au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 4

  1. CVE-2026-32313

    Élevée · CVSS 8.2EPSS 0,16%Correctif disponible

    xmlseclibs is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption

    xmlseclibs is a library written in PHP for working with XML Encryption and Signatures. Prior to 3.1.5, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 3.1.5.

    • Mettez à jour vers 3.1.5
    Publication Mise à jour
  2. CVE-2025-66578

    Moyenne · CVSS 6EPSS 0,24%Correctif disponible

    robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation

    xmlseclibs is a library written in PHP for working with XML Encryption and Signatures. Versions 3.1.3 contain an authentication bypass vulnerability due to a flaw in the libxml2 canonicalization process during document transformation. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. xmlseclibs then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 3.1.4. Workarounds include treating canonicalization failures (exceptions or nil/empty outputs) as fatal and aborting validation,

    • Mettez à jour vers 3.1.4
    Publication Mise à jour
  3. CVE-2019-3465

    Élevée · CVSS 8.8EPSS 2,99%Correctif disponible

    CVE-2019-3465

    Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

    • Mettez à jour vers 2.1.1
    • Mettez à jour vers 3.0.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →