p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de symfony/twig-bridge

Vulnérabilité publiée pour symfony/twig-bridge au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-45072

    Faible · CVSS 2EPSS 0,3%Correctif disponible

    Symfony: Stored XSS in WebProfiler CodeExtension::fileExcerpt() — Unescaped Non-PHP File Rendering

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 6.4.24 until 6.4.40, 7.4.12, and 8.0.12, the development profiler file_excerpt Twig filter escapes PHP files through highlight_string() but interpolates lines from non-PHP files directly into <code> elements, allowing stored XSS against a developer who opens an attacker-written file such as var/log/dev.log in the profiler. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.

    • Mettez à jour vers 6.4.40
    Publication Mise à jour
  2. CVE-2023-46734

    Moyenne · CVSS 6.1EPSS 0,69%Correctif disponible

    Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.

    • Mettez à jour vers 4.4.51
    • Mettez à jour vers 5.4.31
    • Mettez à jour vers 6.3.8
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →