p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de aiograpi

Vulnérabilité publiée pour aiograpi au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-47157

    Moyenne · CVSS 6.5EPSS 0,19%Correctif disponible

    aiograpi: Unsafe signup challenge path handling

    aiograpi is an asynchronous Instagram API for Python. aiograpi versions before 0.9.10 accepted server-supplied signup challenge paths and used them to build request URLs before validating that the paths were relative Instagram API paths. If an attacker can influence a challenge response, for example through a local network, DNS, or proxy compromise, challenge handling requests could be sent outside the intended Instagram host with the client's existing session headers. Version 0.9.10 validates challenge paths before building URLs, solving captcha challenges, or submitting phone/SMS challenge forms.

    • Mettez à jour vers 0.9.10
    Publication Mise à jour
  2. GHSA-7mw3-79jq-xc7f

    Moyenne · CVSS 6.3Correctif disponible

    aiograpi has dependency on vulnerable orjson 3.11.4 (CVE-2025-67221)

    ## Impact aiograpi 0.6.6 / 0.7.0 / 0.7.1 declared `orjson==3.11.6` (and later `==3.11.8`) in `requirements.txt` but `setup.py` carried a hard-coded duplicate `requirements = [...]` list that was never updated and still pinned `orjson==3.11.4`. When `setuptools` builds the source distribution it reads the metadata from `setup.py`, not from `requirements.txt`. So `pip install aiograpi==0.6.6` (or 0.7.0 / 0.7.1) actually pulls `orjson==3.11.4` — a version vulnerable to **CVE-2025-67221** (stack overflow in `orjson.dumps` on deeply nested JSON inputs). ## Practical exploitability Low in the typical aiograpi flow: `orjson` is used to encode re

    • Mettez à jour vers 0.7.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →