p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apache-airflow · Page n° 8

Vulnérabilité publiée pour apache-airflow au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 158

  1. CVE-2020-17515

    Moyenne · CVSS 6.1EPSS 16,21%Correctif disponible

    CVE-2020-17515

    The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions prior to 1.10.13. This is same as CVE-2020-13944 but the implemented fix in Airflow 1.10.13 did not fix the issue completely.

    • Mettez à jour vers 1.10.13
    • Mettez à jour vers 1.10.15rc1
    • Mettez à jour vers 2.0.2rc1
    Publication Mise à jour
  2. CVE-2020-13927

    Critique · CVSS 9.8EPSS 99,78%Dans le catalogue KEVCode d’exploitation publicCorrectif disponible

    CVE-2020-13927

    The previous default setting for Airflow's Experimental API was to allow all API requests without authentication, but this poses security risks to users who miss this fact. From Airflow 1.10.11 the default has been changed to deny all requests by default and is documented at https://airflow.apache.org/docs/1.10.11/security.html#api-authentication. Note this change fixes it for new installs but existing users need to change their config to default `[api]auth_backend = airflow.api.auth.backend.deny_all` as mentioned in the Updating Guide: https://github.com/apache/airflow/blob/1.10.11/UPDATING.md#experimental-api-will-deny-all-request-by-defaul

    • Mettez à jour vers 1.10.11
    Publication Mise à jour
  3. CVE-2020-11983

    Moyenne · CVSS 5.4EPSS 1,77%Correctif disponible

    CVE-2020-11983

    An issue was found in Apache Airflow versions 1.10.10 and below. It was discovered that many of the admin management screens in the new/RBAC UI handled escaping incorrectly, allowing authenticated users with appropriate permissions to create stored XSS attacks.

    • Mettez à jour vers 1.10.11
    • Mettez à jour vers 1.10.11rc1
    Publication Mise à jour
  4. CVE-2020-11982

    Critique · CVSS 9.8EPSS 7,22%Correctif disponible

    CVE-2020-11982

    An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

    • Mettez à jour vers 1.10.11
    • Mettez à jour vers 1.10.11rc1
    Publication Mise à jour
  5. CVE-2020-11981

    Critique · CVSS 9.8EPSS 36,79%Code d’exploitation publicCorrectif disponible

    CVE-2020-11981

    An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.

    • Mettez à jour vers 1.10.11rc1
    Publication Mise à jour
  6. CVE-2020-11978

    Élevée · CVSS 8.8EPSS 99,19%Dans le catalogue KEVCode d’exploitation publicCorrectif disponible

    CVE-2020-11978

    An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting load_examples=False in the config then you are not vulnerable.

    • Mettez à jour vers 1.10.11rc1
    Publication Mise à jour
  7. CVE-2019-12417

    Moyenne · CVSS 4.8EPSS 1,28%Correctif disponible

    CVE-2019-12417

    A malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views. This also presented a Local File Disclosure vulnerability to any file readable by the webserver process.

    • Mettez à jour vers 1.10.6rc1
    Publication Mise à jour
  8. CVE-2018-20245

    Élevée · CVSS 8.7EPSS 1,02%Correctif disponible

    CVE-2018-20245

    The LDAP auth backend (airflow.contrib.auth.backends.ldap_auth) prior to Apache Airflow 1.10.1 was misconfigured and contained improper checking of exceptions which disabled server certificate checking.

    • Mettez à jour vers 1.10.1
    Publication Mise à jour
  9. CVE-2017-17836

    Critique · CVSS 9.8EPSS 3,19%Correctif disponible

    CVE-2017-17836

    In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases used by Airflow. An attacker who has limited access to airflow, whether it be via XSS or by leaving a machine unlocked can exfiltrate all credentials from the system.

    • Mettez à jour vers 1.9.0
    Publication Mise à jour
  10. CVE-2017-12614

    Moyenne · CVSS 6.1EPSS 2,02%Correctif disponible

    CVE-2017-12614

    It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

    • Mettez à jour vers 1.9.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →