p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apm-cli

Vulnérabilité publiée pour apm-cli au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-46383

    Moyenne · CVSS 5.5EPSS 0,45%Correctif disponible

    Microsoft APM: Windows absolute-path tar member overwrite during legacy-bundle probing in `apm install`

    Microsoft APM is an open-source, community-driven dependency manager for AI agents. Prior to 0.13.0, Microsoft APM contains a Windows-specific archive extraction boundary failure in the legacy-bundle probe used by apm install <bundle> on supported Python 3.10 and 3.11 runtimes. When apm install is given a local .tar.gz that is not recognized as a plugin-format bundle, APM probes whether it is a legacy --format apm bundle. On Python versions earlier than 3.12, that probe extracts untrusted tar members with raw tar.extractall() without rejecting Windows absolute member names such as D:/.... This vulnerability is fixed in 0.13.0.

    • Mettez à jour vers 0.13.0
    Publication Mise à jour
  2. CVE-2026-44641

    Élevée · CVSS 7.1EPSS 0,43%Correctif disponible

    Microsoft APM: plugin.json component paths escape plugin root and copy arbitrary host files during install

    Microsoft APM is an open-source, community-driven dependency manager for AI agents. Prior to 0.8.12, Microsoft APM normalizes marketplace plugins by copying plugin components referenced in plugin.json into .apm/. The manifest fields agents, skills, commands, and hooks are attacker-controlled, but the implementation does not enforce that those paths remain inside the plugin directory. A malicious plugin can therefore use absolute paths or ../ traversal paths to copy arbitrary readable host files or directories from the installer's machine during apm install. This vulnerability is fixed in 0.8.12.

    • Mettez à jour vers 0.8.12
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →