p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de guarddog

Vulnérabilité publiée pour guarddog au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 6

  1. CVE-2026-44971

    Élevée · CVSS 8.2EPSS 0,24%Aucun correctif publié

    GuardDog: Blind GitHub URL rewrite in remote project scanning causes SSRF and `GH_TOKEN` exfiltration

    GuardDog is a CLI tool to identify malicious PyPI packages. From 1.0.0 to 2.9.0, the programmatic remote project scanning path rewrites attacker-controlled repository URLs using a blind string replacement and then sends the caller's GitHub credentials with the resulting request. This allows an attacker who can influence the scanned repository URL to trigger SSRF and capture the GH_TOKEN used by GuardDog. This vulnerability is fixed in .

    Publication Mise à jour
  2. CVE-2026-44972

    Moyenne · CVSS 5EPSS 0,11%Aucun correctif publié

    GuardDog: Unsanitized human-readable scan output allows terminal escape injection from malicious package content

    GuardDog is a CLI tool to identify malicious PyPI packages. From 2.6.0 to 2.9.0, GuardDog includes attacker-controlled filenames, file locations, messages, and code snippets in its default human-readable output without escaping terminal control characters. A malicious package can therefore inject ANSI or OSC escape sequences into analyst terminals or CI logs.

    Publication Mise à jour
  3. CVE-2026-22871

    Élevée · CVSS 8.7EPSS 1,06%Correctif disponible

    GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE

    GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, there is a path traversal vulnerability exists in GuardDog's safe_extract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. This vulnerability is fixed in 2.7.1.

    • Mettez à jour vers 2.7.1
    Publication Mise à jour
  4. CVE-2026-22870

    Élevée · CVSS 7.1EPSS 0,51%Correctif disponible

    GuardDog Zip Bomb Vulnerability in safe_extract() Allows DoS

    GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, GuardDog's safe_extract() function does not validate decompressed file sizes when extracting ZIP archives (wheels, eggs), allowing attackers to cause denial of service through zip bombs. A malicious package can consume gigabytes of disk space from a few megabytes of compressed data. This vulnerability is fixed in 2.7.1.

    • Mettez à jour vers 2.7.1
    Publication Mise à jour
  5. CVE-2022-23531

    Moyenne · CVSS 5.8EPSS 0,73%Correctif disponible

    Arbitrary file write when scanning a specially-crafted local PyPI package

    GuardDog is a CLI tool to identify malicious PyPI packages. Versions prior to 0.1.5 are vulnerable to Relative Path Traversal when scanning a specially-crafted local PyPI package. Running GuardDog against a specially-crafted package can allow an attacker to write an arbitrary file on the machine where GuardDog is executed due to a path traversal vulnerability when extracting the .tar.gz file of the package being scanned, which exists by design in the tarfile.TarFile.extractall function. This issue is patched in version 0.1.5.

    • Mettez à jour vers 0.1.5
    Publication Mise à jour
  6. CVE-2022-23530

    Moyenne · CVSS 5.8EPSS 0,75%Correctif disponible

    GuardDog vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package

    GuardDog is a CLI tool to identify malicious PyPI packages. Versions prior to v0.1.8 are vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package. Extracting files using shutil.unpack_archive() from a potentially malicious tarball without validating that the destination file path is within the intended destination directory can cause files outside the destination directory to be overwritten. This issue is patched in version 0.1.8. Potential workarounds include using a safer module, like zipfile, and validating the location of the extracted files and discarding those with malicious paths.

    • Mettez à jour vers 0.1.8
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →