p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de llama-index-core

Vulnérabilité publiée pour llama-index-core au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 10

  1. CVE-2025-6208

    Moyenne · CVSS 5.3EPSS 0,41%Correctif disponible

    Uncontrolled Memory Consumption in run-llama/llama_index

    The `SimpleDirectoryReader` component in `llama_index.core` version 0.12.23 suffers from uncontrolled memory consumption due to a resource management flaw. The vulnerability arises because the user-specified file limit (`num_files_limit`) is applied after all files in a directory are loaded into memory. This can lead to memory exhaustion and degraded performance, particularly in environments with limited resources. The issue is resolved in version 0.12.41.

    • Mettez à jour vers 0.12.41
    Publication Mise à jour
  2. CVE-2025-7647

    Élevée · CVSS 7.3EPSS 0,15%Correctif disponible

    Insecure Temporary File Handling in run-llama/llama_index

    The llama-index-core package, up to version 0.12.44, contains a vulnerability in the `get_cache_dir()` function where a predictable, hardcoded directory path `/tmp/llama_index` is used on Linux systems without proper security controls. This vulnerability allows attackers on multi-user systems to steal proprietary models, poison cached embeddings, or conduct symlink attacks. The issue affects all Linux deployments where multiple users share the same system. The vulnerability is classified under CWE-379, CWE-377, and CWE-367, indicating insecure temporary file creation and potential race conditions.

    • Mettez à jour vers 0.13.0
    Publication Mise à jour
  3. CVE-2025-5302

    Élevée · CVSS 8.6EPSS 0,29%Correctif disponible

    Denial of Service (DOS) in JSONReader in run-llama/llama_index

    A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

    • Mettez à jour vers 0.12.38
    Publication Mise à jour
  4. CVE-2025-6209

    Élevée · CVSS 7.5EPSS 0,62%Correctif disponible

    Arbitrary File Read through Path Traversal in run-llama/llama_index

    A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.

    • Mettez à jour vers 0.12.41
    Publication Mise à jour
  5. CVE-2025-5472

    Moyenne · CVSS 6.5EPSS 0,39%Correctif disponible

    Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index

    The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

    • Mettez à jour vers 0.12.38
    Publication Mise à jour
  6. CVE-2025-3108

    Moyenne · CVSS 5EPSS 0,5%Correctif disponible

    Unsafe Deserialization in JsonPickleSerializer Enables Remote Code Execution in run-llama/llama_index

    A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote code execution due to an insecure fallback to Python's pickle module. JsonPickleSerializer prioritizes deserialization using pickle.loads(), which can execute arbitrary code when processing untrusted data. Attackers can exploit this by crafting malicious payloads to achieve full system compromise. The root cause includes an insecure fallback mechanism, lack of validation or safeguards, misleading design, and violation of Python security guidelines.

    • Mettez à jour vers 0.12.41
    Publication Mise à jour
  7. CVE-2024-12704

    Élevée · CVSS 7.5EPSS 0,83%Correctif disponible

    Denial of Service (DoS) in run-llama/llama_index

    A vulnerability in the LangChainLLM class of the run-llama/llama_index repository, version v0.12.5, allows for a Denial of Service (DoS) attack. The stream_complete method executes the llm using a thread and retrieves the result via the get_response_gen method of the StreamingGeneratorCallbackHandler class. If the thread terminates abnormally before the _llm.predict is executed, there is no exception handling for this case, leading to an infinite loop in the get_response_gen function. This can be triggered by providing an input of an incorrect type, causing the thread to terminate and the process to continue running indefinitely.

    • Mettez à jour vers 0.12.6
    Publication Mise à jour
  8. CVE-2024-3271

    Critique · CVSS 9.8EPSS 2,89%Correctif disponible

    Command Injection in run-llama/llama_index

    A command injection vulnerability exists in the run-llama/llama_index repository, specifically within the safe_eval function. Attackers can bypass the intended security mechanism, which checks for the presence of underscores in code generated by LLM, to execute arbitrary code. This is achieved by crafting input that does not contain an underscore but still results in the execution of OS commands. The vulnerability allows for remote code execution (RCE) on the server hosting the application.

    • Mettez à jour vers 0.10.24
    Publication Mise à jour
  9. CVE-2024-3098

    Critique · CVSS 9.8EPSS 0,96%Correctif disponible

    Prompt Injection leading to Arbitrary Code Execution in run-llama/llama_index

    A vulnerability was identified in the `exec_utils` class of the `llama_index` package, specifically within the `safe_eval` function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.

    • Mettez à jour vers 0.10.24
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →