p PatchFirst

PatchFirst · Vulnérabilités récentes

pypdf 6.21.1 : vulnérabilités connues

Vulnérabilités connues concernant pypdf 6.21.1 : 3. Comparez les versions corrigées ci-dessous avec celle que vous utilisez.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2026-115585

    Élevée · CVSS 7.1EPSS 0,41%Correctif disponible

    pypdf: Possible long runtimes for repeated malformed cross-reference entries (Follow-up)

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an incomplete remediation for repeated malformed cross-reference entries in GHSA-55h5-xmcq-c37v could still trigger a complete PDF stream reload during each recovery attempt even when a recovery cache was present, causing crafted cross-reference streams to produce long runtimes. This issue is fixed in version 6.21.2.

    • Mettez à jour vers 6.21.2
    Publication Mise à jour
  2. CVE-2026-115580

    Élevée · CVSS 7.1EPSS 0,41%Correctif disponible

    pypdf: Possible long runtimes for large xref table header limits

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF with a standard cross-reference table whose declared entry count exceeds what the file can contain, causing excessive processing and long runtimes when the file is opened. This issue is fixed in version 6.21.2.

    • Mettez à jour vers 6.21.2
    Publication Mise à jour
  3. CVE-2026-115572

    Élevée · CVSS 7.1EPSS 0,38%Correctif disponible

    pypdf: Possible long runtimes for repeated references to the same missing object

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF that repeatedly references the same nonexistent indirect object, causing relevant file parts such as pages to trigger repeated full-file recovery loads and long runtimes when accessed. This issue is fixed in version 6.21.2.

    • Mettez à jour vers 6.21.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →