p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de la pile PHP · Page n° 199

Vulnérabilités publiées pour PHP au cours des 30 derniers jours : 222. Présentes dans le catalogue KEV : 2.

Filtrer les vulnérabilités
PHP

Alertes précoces

Signalements récents de vulnérabilités issus des annonces des éditeurs et de l’actualité de la sécurité. Ces alertes ne modifient pas la note de sécurité.

  1. php

    Aucun correctif publié

    PHP : exécution de code à distance

    Selon OpenNet, PHP présente une vulnérabilité d’exécution de code à distance (CVE-2026-115560). Les versions exactes affectées ne sont pas précisées. Le message ne précise pas de version corrigée.

    Que faire maintenant : Vérifiez si une mise à jour de sécurité de PHP contenant le correctif est disponible et installez-la.

    CVE-2026-115560

Vulnérabilités : 7239

  1. CVE-2023-29530

    Élevée · CVSS 7.5EPSS 0,97%Correctif disponible

    Laminas Diactoros vulnerable to HTTP Multiline Header Termination

    Laminas Diactoros provides PSR HTTP Message implementations. In versions 2.18.0 and prior, 2.19.0, 2.20.0, 2.21.0, 2.22.0, 2.23.0, 2.24.0, and 2.25.0, users who create HTTP requests or responses using laminas/laminas-diactoros, when providing a newline at the start or end of a header key or value, can cause an invalid message. This can lead to denial of service vectors or application errors. The problem has been patched in following versions 2.18.1, 2.19.1, 2.20.1, 2.21.1, 2.22.1, 2.23.1, 2.24.1, and 2.25.1. As a workaround, validate HTTP header keys and/or values, and if using user-supplied values, filter them to strip off leading or trailin

    • Mettez à jour vers 2.18.1
    • Mettez à jour vers 2.19.1
    • Mettez à jour vers 2.20.1
    • Mettez à jour vers 2.21.1
    • Mettez à jour vers 2.22.1
    • Mettez à jour vers 2.23.1
    • Mettez à jour vers 2.24.2
    • Mettez à jour vers 2.25.2
    Publication Mise à jour
  2. CVE-2023-31045

    Moyenne · CVSS 4.8EPSS 0,53%Correctif disponible

    CVE-2023-31045

    A stored Cross-site scripting (XSS) issue in Text Editors and Formats in Backdrop CMS before 1.24.2 allows remote attackers to inject arbitrary web script or HTML via the name parameter. When a user is editing any content type (e.g., page, post, or card) as an admin, the stored XSS payload is executed upon selecting a malicious text formatting option. NOTE: the vendor disputes the security relevance of this finding because "any administrator that can configure a text format could easily allow Full HTML anywhere."

    • Mettez à jour vers 1.24.2
    Publication Mise à jour
  3. GHSA-wjfc-pgfp-pv9c

    Moyenne · CVSS 5.3Correctif disponible

    Improper Input Validation in nyholm/psr7

    ### Impact Improper header parsing. An attacker could sneak in a newline (`\n`) into both the header names and values. While the specification states that `\r\n\r\n` is used to terminate the header list, many servers in the wild will also accept `\n\n`. ### Patches The issue is patched in 1.6.1. ### Workarounds There are no known workarounds. ### References * https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4

    • Mettez à jour vers 1.6.1
    Publication Mise à jour
  4. GHSA-9jxr-mwpp-w643

    Moyenne · CVSS 5.3Correctif disponible

    Improper header validation in httpsoft/http-message

    ### Impact Improper header parsing. An attacker could sneak in a newline (`\n`) into both the header names and values. While the specification states that `\r\n\r\n` is used to terminate the header list, many servers in the wild will also accept `\n\n`. ### Patches The issue is patched in 1.0.12. ### Workarounds There are no known workarounds. ### References * https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4

    • Mettez à jour vers 1.0.12
    Publication Mise à jour
  5. CVE-2023-30536

    Moyenne · CVSS 6.5EPSS 0,74%Correctif disponible

    Insecure header validation in slim/psr7

    slim/psr7 is a PSR-7 implementation for use with Slim 4. In versions prior to 1.6.1 an attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the appl

    • Mettez à jour vers 1.4.1
    • Mettez à jour vers 1.5.1
    • Mettez à jour vers 1.6.1
    • Mettez à jour vers 1.6.1-1
    Publication Mise à jour
  6. CVE-2023-29197

    Moyenne · CVSS 5.3EPSS 1,22%Correctif disponible

    Improper header name validation in guzzlehttp/psr7

    guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.

    • Mettez à jour vers 1.4.2-0.1+deb10u2build0.20.04.1
    • Mettez à jour vers 1.5.0-1ubuntu0.1~esm1
    • Mettez à jour vers 1.5.1-2
    • Mettez à jour vers 1.8.3-1ubuntu0.1~esm1
    • Mettez à jour vers 1.9.1
    • Mettez à jour vers 2.4.5
    • Mettez à jour vers 2.4.5-1
    Publication Mise à jour
  7. CVE-2023-2017

    Élevée · CVSS 8.8EPSS 2,07%Correctif disponible

    Improper Control of Generation of Code in Twig Rendered Views in Shopware

    Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.

    • Mettez à jour vers 6.4.20.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →