SUSE-SU-2022:3661-1
SUSE-SU-2022:3661-1 · Security update for php8
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for php8 fixes the following issues: - php8 was updated to version 8.0.24 - php8 was updated to version 8.0.23 (jsc#SLE-23639). - CVE-2021-21703: Fixed a local privilege escalation via PHP-FPM. (bsc#1192050) - CVE-2022-31628: Fixed an uncontrolled recursion in the phar uncompressor while decompressing 'quines' gzip files. (bsc#1203867) - CVE-2022-31629: Fixed a bug which could lead an attacker to set an insecure cookie that will treated as secure in the victim's browser. (bsc#1203870) - Fixed missing devel package requires pear and pecl extensions (jsc#SLE-24723, bsc#1200772).
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
apache2-mod_php8 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-embed openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-fastcgi openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-fpm openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
php8-test openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.24-150400.4.14.1
Mettez à jour vers 8.0.24-150400.4.14.1
Sources originales
- https://www.suse.com/support/update/announcement/2022/suse-su-20223661-1/
- https://bugzilla.suse.com/1192050
- https://bugzilla.suse.com/1200772
- https://bugzilla.suse.com/1203867
- https://bugzilla.suse.com/1203870
- https://www.suse.com/security/cve/CVE-2021-21703
- https://www.suse.com/security/cve/CVE-2022-31628
- https://www.suse.com/security/cve/CVE-2022-31629
- https://osv.dev/vulnerability/SUSE-SU-2022:3661-1