SUSE-SU-2022:4005-1
SUSE-SU-2022:4005-1 · Security update for php8
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for php8 fixes the following issues: - CVE-2022-37454: Fixed buffer overflow in hash_update() on long parameter (bug#81738) (bsc#1204577). - CVE-2022-31630: Fixed OOB read due to insufficient input validation in imageloadfont() (bug#81739) (bsc#1204979). - version update to 8.0.25 (27 Oct 2022) * Session: Fixed bug GH-9583 (session_create_id() fails with user defined save handler that doesn't have a validateId() method). * Streams: Fixed bug GH-9590 (stream_select does not abort upon exception or empty valid fd set).
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
apache2-mod_php8 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-embed openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-fastcgi openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-fpm openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1
php8-test openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 8.0.25-150400.4.17.1
Mettez à jour vers 8.0.25-150400.4.17.1