p PatchFirst

SUSE-SU-2023:4558-1

SUSE-SU-2023:4558-1 · Security update for webkit2gtk3

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

This update for webkit2gtk3 fixes the following issues: Update to version 2.42.2 (bsc#1217210): - CVE-2023-41983: Processing web content may lead to a denial-of-service. - CVE-2023-42852: Processing web content may lead to arbitrary code execution. Already previously fixed: - CVE-2022-32919: Visiting a website that frames malicious content may lead to UI spoofing (fixed already in 2.38.4). - CVE-2022-32933: A website may be able to track the websites a user visited in private browsing mode (fixed already in 2.38.0). - CVE-2022-46705: Visiting a malicious website may lead to address bar spoofing (fixed already in 2.38.4). - CVE-2022-46725: Visiting a malicious website may lead to address bar spoofing (fixed already in 2.38.4). - CVE-2023-32359: A user’s password may be read aloud by a text-to-speech accessibility feature (fixed already in 2.42.0). Bug fixes: - Disable DMABuf renderer for NVIDIA proprietary drivers (bsc#1216778).

Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

  • webkit2gtk3 SUSE:Enterprise Storage 7.1

    Plages de versions concernées
    • ECOSYSTEM: < 2.42.2-150200.91.1

    Mettez à jour vers 2.42.2-150200.91.1

Sources originales

Vérifiez votre serveur →