p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de mercurial

Vulnérabilité publiée pour mercurial au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 14

  1. CVE-2014-9390

    Critique · CVSS 9.8EPSS 75,6%Code d’exploitation publicCorrectif disponible

    CVE-2014-9390

    Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.

    • Mettez à jour vers 2.8.2-1ubuntu1.3
    Publication Mise à jour
  2. CVE-2018-1000132

    Critique · CVSS 9.3EPSS 2,62%Correctif disponible

    CVE-2018-1000132

    Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

    • Mettez à jour vers 2.8.2-1ubuntu1.4
    Publication Mise à jour
  3. CVE-2017-17458

    Critique · CVSS 9.8EPSS 6,33%Correctif disponible

    CVE-2017-17458

    In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.

    • Mettez à jour vers 2.8.2-1ubuntu1.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →