p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ruby2.0 · Page n° 2

Vulnérabilité publiée pour ruby2.0 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 38

  1. CVE-2018-1000074

    Élevée · CVSS 7.8EPSS 2,88%Correctif disponible

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.10
    Publication Mise à jour
  2. CVE-2018-1000073

    Élevée · CVSS 7.5EPSS 4,91%Correctif disponible

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.6
    Publication Mise à jour
  3. CVE-2017-17405

    Élevée · CVSS 8.8EPSS 73,83%Code d’exploitation publicCorrectif disponible

    CVE-2017-17405

    Ruby before 2.4.3 allows Net::FTP command injection. Net::FTP#get, getbinaryfile, gettextfile, put, putbinaryfile, and puttextfile use Kernel#open to open a local file. If the localfile argument starts with the "|" pipe character, the command following the pipe character is executed. The default value of localfile is File.basename(remotefile), so malicious FTP servers could cause arbitrary command execution.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.5
    Publication Mise à jour
  4. CVE-2017-0903

    Critique · CVSS 9.8EPSS 15,85%Correctif disponible

    CVE-2017-0903

    RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.10
    Publication Mise à jour
  5. CVE-2017-10784

    Élevée · CVSS 8.8EPSS 16,41%Correctif disponible

    CVE-2017-10784

    The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.10
    Publication Mise à jour
  6. CVE-2017-0898

    Critique · CVSS 9.1EPSS 9,72%Correctif disponible

    CVE-2017-0898

    Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.10
    Publication Mise à jour
  7. CVE-2017-14064

    Critique · CVSS 9.8EPSS 9,45%Correctif disponible

    CVE-2017-14064

    Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call. The issues lies in using strdup in ext/json/ext/generator/generator.c, which will stop after encountering a '\0' byte, returning a pointer to a string of length zero, which is not the length stored in space_len.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.10
    Publication Mise à jour
  8. CVE-2016-2339

    Critique · CVSS 9.8EPSS 5,14%Correctif disponible

    CVE-2016-2339

    An exploitable heap overflow vulnerability exists in the Fiddle::Function.new "initialize" function functionality of Ruby. In Fiddle::Function.new "initialize" heap buffer "arg_types" allocation is made based on args array length. Specially constructed object passed as element of args array can increase this array size after mentioned allocation and cause heap overflow.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.4
    Publication Mise à jour
  9. CVE-2015-7551

    Élevée · CVSS 8.4EPSS 0,5%Correctif disponible

    CVE-2015-7551

    The Fiddle::Handle implementation in ext/fiddle/handle.c in Ruby before 2.0.0-p648, 2.1 before 2.1.8, and 2.2 before 2.2.4, as distributed in Apple OS X before 10.11.4 and other products, mishandles tainting, which allows context-dependent attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted string, related to the DL module and the libffi library. NOTE: this vulnerability exists because of a CVE-2009-5147 regression.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.4
    Publication Mise à jour
  10. CVE-2014-8090

    Non évaluéeEPSS 5,71%Correctif disponible

    CVE-2014-8090

    The REXML parser in Ruby 1.9.x before 1.9.3 patchlevel 551, 2.0.x before 2.0.0 patchlevel 598, and 2.1.x before 2.1.5 allows remote attackers to cause a denial of service (CPU and memory consumption) a crafted XML document containing an empty string in an entity that is used in a large number of nested entity references, aka an XML Entity Expansion (XEE) attack. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-1821 and CVE-2014-8080.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.2
    Publication Mise à jour
  11. CVE-2014-4975

    Non évaluéeEPSS 3,46%Correctif disponible

    CVE-2014-4975

    Off-by-one error in the encodes function in pack.c in Ruby 1.9.3 and earlier, and 2.x through 2.1.2, when using certain format string specifiers, allows context-dependent attackers to cause a denial of service (segmentation fault) via vectors that trigger a stack-based buffer overflow.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.1
    Publication Mise à jour
  12. CVE-2013-4164

    Non évaluéeEPSS 34,97%Code d’exploitation publicCorrectif disponible

    CVE-2013-4164

    Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.

    • Mettez à jour vers 2.0.0.343-1ubuntu1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →