p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ruby2.0

Vulnérabilités publiées pour ruby2.0 au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 38

  1. CVE-2015-1855

    Moyenne · CVSS 5.9EPSS 2,81%Correctif disponible

    CVE-2015-1855

    verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers via vectors related to (1) multiple wildcards, (1) wildcards in IDNA names, (3) case sensitivity, and (4) non-ASCII characters.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.4
    Publication Mise à jour
  2. CVE-2019-8324

    Élevée · CVSS 8.8EPSS 3,22%Correctif disponible

    CVE-2019-8324

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.13
    Publication Mise à jour
  3. CVE-2019-8320

    Élevée · CVSS 7.4EPSS 4,19%Correctif disponible

    CVE-2019-8320

    A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.13
    Publication Mise à jour
  4. CVE-2018-16395

    Critique · CVSS 9.8EPSS 10,71%Correctif disponible

    CVE-2018-16395

    An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.11
    Publication Mise à jour
  5. CVE-2018-8780

    Critique · CVSS 9.1EPSS 9,98%Correctif disponible

    CVE-2018-8780

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters. When using the corresponding method, unintentional directory traversal may be performed.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.9
    Publication Mise à jour
  6. CVE-2018-8778

    Élevée · CVSS 7.5EPSS 7,53%Correctif disponible

    CVE-2018-8778

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker controlling the unpacking format (similar to format string vulnerabilities) can trigger a buffer under-read in the String#unpack method, resulting in a massive and controlled information disclosure.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.9
    Publication Mise à jour
  7. CVE-2018-8777

    Élevée · CVSS 7.5EPSS 4,46%Correctif disponible

    CVE-2018-8777

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).

    • Mettez à jour vers 2.0.0.484-1ubuntu2.10
    Publication Mise à jour
  8. CVE-2018-6914

    Élevée · CVSS 7.5EPSS 10,16%Correctif disponible

    CVE-2018-6914

    Directory traversal vulnerability in the Dir.mktmpdir method in the tmpdir library in Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 might allow attackers to create arbitrary directories or files via a .. (dot dot) in the prefix argument.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.9
    Publication Mise à jour
  9. CVE-2018-1000079

    Moyenne · CVSS 5.5EPSS 2,78%Correctif disponible

    CVE-2018-1000079

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.6
    Publication Mise à jour
  10. CVE-2018-1000078

    Moyenne · CVSS 6.1EPSS 2,75%Correctif disponible

    CVE-2018-1000078

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.6
    Publication Mise à jour
  11. CVE-2018-1000077

    Moyenne · CVSS 5.3EPSS 3,6%Correctif disponible

    CVE-2018-1000077

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.6
    Publication Mise à jour
  12. CVE-2018-1000076

    Critique · CVSS 9.8EPSS 2,93%Correctif disponible

    CVE-2018-1000076

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.6
    Publication Mise à jour
  13. CVE-2018-1000075

    Élevée · CVSS 7.5EPSS 4,74%Correctif disponible

    CVE-2018-1000075

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.0.0.484-1ubuntu2.6
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →