p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de python-werkzeug

Vulnérabilité publiée pour python-werkzeug au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2023-25577

    Élevée · CVSS 7.5EPSS 1,42%Correctif disponible

    Werkzeug may allow high resource usage when parsing multipart form data with many fields

    Werkzeug is a comprehensive WSGI web application library. Prior to version 2.2.3, Werkzeug's multipart form data parser will parse an unlimited number of parts, including file parts. Parts can be a small amount of bytes, but each requires CPU time to parse and may use more memory as Python data. If a request can be made to an endpoint that accesses `request.data`, `request.form`, `request.files`, or `request.get_data(parse_form_data=False)`, it can cause unexpectedly high resource usage. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can

    • Mettez à jour vers 0.14.1+dfsg1-1ubuntu0.2
    Publication Mise à jour
  2. CVE-2023-23934

    Faible · CVSS 2.6EPSS 0,51%Correctif disponible

    Wrkzeug's incorrect parsing of nameless cookies leads to __Host- cookies bypass

    Werkzeug is a comprehensive WSGI web application library. Browsers may allow "nameless" cookies that look like `=value` instead of `key=value`. A vulnerable browser may allow a compromised application on an adjacent subdomain to exploit this to set a cookie like `=__Host-test=bad` for another subdomain. Werkzeug prior to 2.2.3 will parse the cookie `=__Host-test=bad` as __Host-test=bad`. If a Werkzeug application is running next to a vulnerable or malicious subdomain which sets such a cookie using a vulnerable browser, the Werkzeug application will see the bad cookie value but the valid cookie key. The issue is fixed in Werkzeug 2.2.3.

    • Mettez à jour vers 0.14.1+dfsg1-1ubuntu0.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →