p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de smarty3

Vulnérabilité publiée pour smarty3 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2024-35226

    Élevée · CVSS 7.3EPSS 0,51%Correctif disponible

    PHP Code Injection by malicious attribute in extends-tag in Smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. In affected versions template authors could inject php code by choosing a malicious file name for an extends-tag. Sites that cannot fully trust template authors should update asap. All users are advised to update. There is no patch for users on the v3 branch. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
    Publication Mise à jour
  2. CVE-2023-28447

    Élevée · CVSS 7.1EPSS 1,02%Correctif disponible

    Cross site scripting vulnerability in Javascript escaping in smarty/smarty

    Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
    Publication Mise à jour
  3. CVE-2018-25047

    Moyenne · CVSS 5.4EPSS 1,1%Correctif disponible

    CVE-2018-25047

    In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

    • Mettez à jour vers 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →