p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de qtbase-opensource-src

Vulnérabilités publiées pour qtbase-opensource-src au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 7

  1. CVE-2025-5455

    Élevée · CVSS 8.4EPSS 0,38%Aucun correctif publié

    Possible denial of service when passing malformed data in a URL to qDecodeDataUrl

    An issue was found in the private API function qDecodeDataUrl() in QtCore, which is used in QTextDocument and QNetworkReply, and, potentially, in user code. If the function was called with malformed data, for example, an URL that contained a "charset" parameter that lacked a value (such as "data:charset,"), and Qt was built with assertions enabled, then it would hit an assertion, resulting in a denial of service (abort). This impacts Qt up to 5.15.18, 6.0.0->6.5.8, 6.6.0->6.8.3 and 6.9.0. This has been fixed in 5.15.19, 6.5.9, 6.8.4 and 6.9.1.

    Publication Mise à jour
  2. CVE-2025-4211

    Élevée · CVSS 7.3EPSS 0,21%Aucun correctif publié

    Improper Link Resolution Before File Access in QFileSystemEngine on Windows

    Improper Link Resolution Before File Access ('Link Following') vulnerability in QFileSystemEngine in the Qt corelib module on Windows which potentially allows Symlink Attacks and the use of Malicious Files. Issue originates from CVE-2024-38081. The vulnerability arises from the use of the GetTempPath API, which can be exploited by attackers to manipulate temporary file paths, potentially leading to unauthorized access and privilege escalation. The affected public API in the Qt Framework is QDir::tempPath() and anything that uses it, such as QStandardPaths with TempLocation, QTemporaryDir, and QTemporaryFile. This issue affects all version of

    Publication Mise à jour
  3. CVE-2024-39936

    Élevée · CVSS 8.6EPSS 0,49%Aucun correctif publié

    CVE-2024-39936

    An issue was discovered in HTTP2 in Qt before 5.15.18, 6.x before 6.2.13, 6.3.x through 6.5.x before 6.5.7, and 6.6.x through 6.7.x before 6.7.3. Code to make security-relevant decisions about an established connection may execute too early, because the encrypted() signal has not yet been emitted and processed..

    Publication Mise à jour
  4. CVE-2023-43114

    Moyenne · CVSS 5.5EPSS 0,27%Aucun correctif publié

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →