p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de python-jwcrypto

Vulnérabilité publiée pour python-jwcrypto au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2026-39373

    Moyenne · CVSS 5.3EPSS 0,29%Aucun correctif publié

    JWCrypto: JWE ZIP decompression bomb

    JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to 1.5.7, an unauthenticated attacker can exhaust server memory by sending crafted JWE tokens with ZIP compression. The existing patch for CVE-2024-28102 limits input token size to 250KB but does not validate the decompressed output size. An unauthenticated attacker can cause memory exhaustion on memory-constrained systems. A token under the 250KB input limit can decompress to approximately 100MB. This vulnerability is fixed in 1.5.7.

    Publication Mise à jour
  2. CVE-2024-28102

    Moyenne · CVSS 6.8EPSS 0,98%Aucun correctif publié

    JWCrypto vulnerable to JWT bomb Attack in `deserialize` function

    JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to version 1.5.6, an attacker can cause a denial of service attack by passing in a malicious JWE Token with a high compression ratio. When the server processes this token, it will consume a lot of memory and processing time. Version 1.5.6 fixes this vulnerability by limiting the maximum token length.

    Publication Mise à jour
  3. CVE-2023-6681

    Moyenne · CVSS 5.3EPSS 0,88%Aucun correctif publié

    Jwcrypto: denail of service via specifically crafted jwe

    A vulnerability was found in JWCrypto. This flaw allows an attacker to cause a denial of service (DoS) attack and possible password brute-force and dictionary attacks to be more resource-intensive. This issue can result in a large amount of computational consumption, causing a denial of service attack.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →