p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de wlc

Vulnérabilité publiée pour wlc au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 4

  1. CVE-2026-42150

    Moyenne · CVSS 5.1EPSS 0,17%Aucun correctif publié

    wlc: print_html outputs API data without HTML escaping, enabling stored XSS

    wlc is a Weblate command-line client using Weblate's REST API. Prior to version 2.0.0, the HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser. This issue has been patched in version 2.0.0.

    Publication Mise à jour
  2. CVE-2026-22251

    Moyenne · CVSS 5.3EPSS 0,19%Correctif disponible

    wlc may leak API keys due to an insecure API key configuration

    wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, wlc supported providing unscoped API keys in the setting. This practice was discouraged for years, but the code was never removed. This might cause the API key to be leaked to different servers.

    • Mettez à jour vers 1.15-2ubuntu0.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →