p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apr-util

Vulnérabilité publiée pour apr-util au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 4

  1. CVE-2025-49506

    Élevée · CVSS 7.5EPSS 0,38%Correctif disponible

    Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

    APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Mettez à jour vers 1.6.3-3ubuntu3.1
    Publication Mise à jour
  2. CVE-2026-32327

    Critique · CVSS 9.1EPSS 0,46%Correctif disponible

    Apache Portable Runtime Utility: apr-util XML stack recursion crash

    A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Mettez à jour vers 1.6.3-3ubuntu3.1
    Publication Mise à jour
  3. CVE-2026-34501

    Élevée · CVSS 7.5EPSS 0,51%Correctif disponible

    Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

    • Mettez à jour vers 1.6.3-3ubuntu3.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →