p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de poco

Vulnérabilités publiées pour poco au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 4

  1. CVE-2025-45766

    Élevée · CVSS 7EPSS 0,14%Aucun correctif publié

    CVE-2025-45766

    poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.

    Publication Mise à jour
  2. CVE-2025-6375

    Moyenne · CVSS 4.8EPSS 0,26%Aucun correctif publié

    poco MultipartReader.cpp MultipartInputStream null pointer dereference

    A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.

    Publication Mise à jour
  3. CVE-2023-52389

    Critique · CVSS 9.8EPSS 0,85%Aucun correctif publié

    CVE-2023-52389

    UTF32Encoding.cpp in POCO has a Poco::UTF32Encoding integer overflow and resultant stack buffer overflow because Poco::UTF32Encoding::convert() and Poco::UTF32::queryConvert() may return a negative integer if a UTF-32 byte sequence evaluates to a value of 0x80000000 or higher. This is fixed in 1.11.8p2, 1.12.5p2, and 1.13.0.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →