p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de qtbase-opensource-src-gles

Vulnérabilités publiées pour qtbase-opensource-src-gles au cours des 30 derniers jours : 3. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 18

  1. CVE-2026-16762

    Élevée · CVSS 8.7EPSS 0,52%Aucun correctif publié

    Denial-of-service vulnerability in the Qt Core QXmlStream parser (QXmlStreamReader) impacts Qt

    An attacker able to supply a crafted XML document to an application using QXmlStreamReader can cause disproportionate CPU consumption during parsing, making the application unresponsive (denial of service). Exploitation requires only that the application parse attacker-influenced XML; no authentication, privileges, or user interaction beyond ingesting the input are needed. There is no loss of confidentiality or integrity — no data disclosure, data modification, or code execution — and the impact is contained to the affected process.

    Publication Mise à jour
  2. CVE-2025-14575

    Faible · CVSS 1.8EPSS 0,09%Aucun correctif publié

    Uncontrolled Search Path Element in Qt Network OpenSSL TLS backend allows rogue CA certificate loading

    An Uncontrolled Search Path Element vulnerability in the OpenSSL TLS backend of Qt Network (qtbase) in Qt Qt Framework (Unix) allows a local attacker to load a rogue CA certificate as a trusted system authority via a crafted certificate file placed in the application's working directory.

    Publication Mise à jour
  3. CVE-2025-5991

    Faible · CVSS 2.1EPSS 0,14%Aucun correctif publié

    Use after free in QHttp2ProtocolHandler

    There is a "Use After Free" vulnerability in Qt's QHttp2ProtocolHandler in the QtNetwork module. This only affects HTTP/2 handling, HTTP handling is not affected by this at all. This happens due to a race condition between how QHttp2Stream uploads the body of a POST request and the simultaneous handling of HTTP error responses. This issue only affects Qt 6.9.0 and has been fixed for Qt 6.9.1.

    Publication Mise à jour
  4. CVE-2025-5455

    Élevée · CVSS 8.4EPSS 0,38%Aucun correctif publié

    Possible denial of service when passing malformed data in a URL to qDecodeDataUrl

    An issue was found in the private API function qDecodeDataUrl() in QtCore, which is used in QTextDocument and QNetworkReply, and, potentially, in user code. If the function was called with malformed data, for example, an URL that contained a "charset" parameter that lacked a value (such as "data:charset,"), and Qt was built with assertions enabled, then it would hit an assertion, resulting in a denial of service (abort). This impacts Qt up to 5.15.18, 6.0.0->6.5.8, 6.6.0->6.8.3 and 6.9.0. This has been fixed in 5.15.19, 6.5.9, 6.8.4 and 6.9.1.

    Publication Mise à jour
  5. CVE-2025-4211

    Élevée · CVSS 7.3EPSS 0,21%Aucun correctif publié

    Improper Link Resolution Before File Access in QFileSystemEngine on Windows

    Improper Link Resolution Before File Access ('Link Following') vulnerability in QFileSystemEngine in the Qt corelib module on Windows which potentially allows Symlink Attacks and the use of Malicious Files. Issue originates from CVE-2024-38081. The vulnerability arises from the use of the GetTempPath API, which can be exploited by attackers to manipulate temporary file paths, potentially leading to unauthorized access and privilege escalation. The affected public API in the Qt Framework is QDir::tempPath() and anything that uses it, such as QStandardPaths with TempLocation, QTemporaryDir, and QTemporaryFile. This issue affects all version of

    Publication Mise à jour
  6. CVE-2025-3512

    Moyenne · CVSS 4.8EPSS 0,23%Aucun correctif publié

    Buffer overflow in QTextMarkdownImporter

    There is a Heap-based Buffer Overflow vulnerability in QTextMarkdownImporter. This requires an incorrectly formatted markdown file to be passed to QTextMarkdownImporter to trigger the overflow. This issue affects Qt from 6.8.0 to 6.8.4. Versions up to 6.6.0 are known to be unaffected, and the fix is in 6.8.4 and later.

    Publication Mise à jour
  7. CVE-2023-43114

    Moyenne · CVSS 5.5EPSS 0,27%Aucun correctif publié

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Publication Mise à jour
  8. CVE-2023-32762

    Moyenne · CVSS 5.3EPSS 0,88%Aucun correctif publié

    CVE-2023-32762

    An issue was discovered in Qt before 5.15.14, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.1. Qt Network incorrectly parses the strict-transport-security (HSTS) header, allowing unencrypted connections to be established, even when explicitly prohibited by the server. This happens if the case used for this header does not exactly match.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →