p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apr-util

Vulnérabilité publiée pour apr-util au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 7

  1. CVE-2025-49506

    Élevée · CVSS 7.5EPSS 0,38%Correctif disponible

    Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

    APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Mettez à jour vers 1.5.3-1ubuntu0.1~esm3
    Publication Mise à jour
  2. CVE-2026-32327

    Critique · CVSS 9.1EPSS 0,46%Correctif disponible

    Apache Portable Runtime Utility: apr-util XML stack recursion crash

    A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Mettez à jour vers 1.5.3-1ubuntu0.1~esm3
    Publication Mise à jour
  3. CVE-2026-34501

    Élevée · CVSS 7.5EPSS 0,51%Correctif disponible

    Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

    • Mettez à jour vers 1.5.3-1ubuntu0.1~esm3
    Publication Mise à jour
  4. CVE-2022-25147

    Moyenne · CVSS 6.5EPSS 1,43%Correctif disponible

    Apache Portable Runtime Utility (APR-util): out-of-bounds writes in the apr_base64 family of functions

    Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.

    • Mettez à jour vers 1.5.3-1ubuntu0.1~esm2
    Publication Mise à jour
  5. CVE-2017-12618

    Moyenne · CVSS 4.7EPSS 0,6%Correctif disponible

    CVE-2017-12618

    Apache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.

    • Mettez à jour vers 1.5.3-1ubuntu0.1~esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →