p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de gst-plugins-bad0.10

Vulnérabilités publiées pour gst-plugins-bad0.10 au cours des 30 derniers jours : 2. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 12

  1. CVE-2026-111271

    Moyenne · CVSS 6.8EPSS 0,19%Aucun correctif publié

    libmodplug through 0.8.9.1 Heap Out-of-Bounds Read via CSoundFile::ReadAMS2

    libmodplug through 0.8.9.1 contains a heap-based out-of-bounds read vulnerability in CSoundFile::ReadAMS2() in src/load_ams.cpp that allows attackers to read adjacent heap memory via crafted AMS files. Attackers can supply an AMS module whose pattern effect bytes keep bit 7 set, driving the decoder past the input buffer and crashing any libmodplug consumer.

    Publication Mise à jour
  2. CVE-2026-111270

    Moyenne · CVSS 6.9EPSS 0,2%Aucun correctif publié

    libmodplug through 0.8.9.1 Heap Out-of-Bounds Write via CSoundFile::ReadDSM

    libmodplug through 0.8.9.1 contains a heap-based out-of-bounds write in CSoundFile::ReadDSM() in src/load_dsm.cpp because nPat is never checked against MAX_PATTERNS. Attackers can supply a crafted DSM file with over 240 PATT chunks or a wrapping patt_len value to corrupt heap memory and crash the consuming process.

    Publication Mise à jour
  3. CVE-2026-75904

    Moyenne · CVSS 4.8EPSS 0,19%Aucun correctif publié

    libmodplug <= 0.8.9.1 - Out-of-Bounds Read in pat_smplooped via Crafted MIDI File

    libmodplug through 0.8.9.1 contains an out-of-bounds read in pat_smplooped in src/load_pat.cpp. The function validates only the upper bound of its sample index against MAXSMP and then subtracts one before indexing the 191-byte static array pat_loops, so an index of zero reads pat_loops[-1], one byte before the array. The index is the smpno field of a parsed MIDI event, which is initialised to zero and only later overwritten from a program-change parameter, so an event reaching the note test before an instrument is assigned carries zero. A 32-byte MIDI file supplied to the library's public ModPlug_Load entry point drives the path through CSoun

    Publication Mise à jour
  4. CVE-2023-50186

    Élevée · CVSS 7.5EPSS 1,53%Aucun correctif publié

    GStreamer AV1 Video Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability

    GStreamer AV1 Video Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of metadata within AV1 encoded video files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of t

    Publication Mise à jour
  5. CVE-2023-44446

    Élevée · CVSS 8.8EPSS 1,96%Aucun correctif publié

    GStreamer MXF File Parsing Use-After-Free Remote Code Execution Vulnerability

    GStreamer MXF File Parsing Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of MXF video files. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22299.

    Publication Mise à jour
  6. CVE-2023-44429

    Élevée · CVSS 8.8EPSS 1,81%Aucun correctif publié

    GStreamer AV1 Codec Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability

    GStreamer AV1 Codec Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of AV1 encoded video files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process

    Publication Mise à jour
  7. CVE-2023-40475

    Élevée · CVSS 8.8EPSS 2,1%Aucun correctif publié

    GStreamer MXF File Parsing Integer Overflow Remote Code Execution Vulnerability

    GStreamer MXF File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of MXF video files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-21661

    Publication Mise à jour
  8. CVE-2023-40474

    Élevée · CVSS 8.8EPSS 2,1%Aucun correctif publié

    GStreamer MXF File Parsing Integer Overflow Remote Code Execution Vulnerability

    GStreamer MXF File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of MXF video files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-21660

    Publication Mise à jour
  9. CVE-2023-37329

    Élevée · CVSS 8.8EPSS 1,64%Aucun correctif publié

    GStreamer SRT File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability

    GStreamer SRT File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of SRT subtitle files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-20968

    Publication Mise à jour
  10. CVE-2017-5843

    Élevée · CVSS 7.5EPSS 3,8%Correctif disponible

    CVE-2017-5843

    Multiple use-after-free vulnerabilities in the (1) gst_mini_object_unref, (2) gst_tag_list_unref, and (3) gst_mxf_demux_update_essence_tracks functions in GStreamer before 1.10.3 allow remote attackers to cause a denial of service (crash) via vectors involving stream tags, as demonstrated by 02785736.mxf.

    • Mettez à jour vers 0.10.23-7.2ubuntu1.3+esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →