p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de libxslt

Vulnérabilité publiée pour libxslt au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 9

  1. CVE-2025-11731

    Faible · CVSS 3.1EPSS 0,28%Aucun correctif publié

    Libxslt: type confusion in exsltfuncresultcompfunction of libxslt

    A flaw was found in the exsltFuncResultComp() function of libxslt, which handles EXSLT <func:result> elements during stylesheet parsing. Due to improper type handling, the function may treat an XML document node as a regular XML element node, resulting in a type confusion. This can cause unexpected memory reads and potential crashes. While difficult to exploit, the flaw could lead to application instability or denial of service.

    Publication Mise à jour
  2. CVE-2025-7424

    Élevée · CVSS 7.5EPSS 1,3%Correctif disponible

    Libxslt: type confusion in xmlnode.psvi between stylesheet and source nodes

    A flaw was found in the libxslt library. The same memory field, psvi, is used for both stylesheet and input data, which can lead to type confusion during XML transformations. This vulnerability allows an attacker to crash the application or corrupt memory. In some cases, it may lead to denial of service or unexpected behavior.

    • Mettez à jour vers 1.1.28-2.1ubuntu0.3+esm4
    Publication Mise à jour
  3. CVE-2025-24855

    Élevée · CVSS 7.8EPSS 0,36%Correctif disponible

    CVE-2025-24855

    numbers.c in libxslt before 1.1.43 has a use-after-free because, in nested XPath evaluations, an XPath context node can be modified but never restored. This is related to xsltNumberFormatGetValue, xsltEvalXPathPredicate, xsltEvalXPathStringNs, and xsltComputeSortResultInternal.

    • Mettez à jour vers 1.1.28-2.1ubuntu0.3+esm3
    Publication Mise à jour
  4. CVE-2023-40403

    Moyenne · CVSS 6.5EPSS 1,33%Correctif disponible

    CVE-2023-40403

    The issue was addressed with improved memory handling. This issue is fixed in macOS Ventura 13.6, tvOS 17, iOS 16.7 and iPadOS 16.7, macOS Monterey 12.7, watchOS 10, iOS 17 and iPadOS 17, macOS Sonoma 14. Processing web content may disclose sensitive information.

    • Mettez à jour vers 1.1.28-2.1ubuntu0.3+esm2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →