p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de phpmyadmin

Vulnérabilité publiée pour phpmyadmin au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 87

  1. CVE-2025-3573

    Moyenne · CVSS 5.3EPSS 0,36%Aucun correctif publié

    CVE-2025-3573

    Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.

    Publication Mise à jour
  2. CVE-2021-21252

    Moyenne · CVSS 5.3EPSS 3,57%Aucun correctif publié

    Regular expression denial of service in jquery-validation

    The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

    Publication Mise à jour
  3. CVE-2020-10802

    Élevée · CVSS 8EPSS 1,82%Aucun correctif publié

    CVE-2020-10802

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

    Publication Mise à jour
  4. CVE-2020-10803

    Moyenne · CVSS 5.4EPSS 1,37%Aucun correctif publié

    CVE-2020-10803

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.

    Publication Mise à jour
  5. CVE-2020-10804

    Élevée · CVSS 8EPSS 2,35%Aucun correctif publié

    CVE-2020-10804

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

    Publication Mise à jour
  6. CVE-2020-5504

    Élevée · CVSS 8.8EPSS 39,04%Code d’exploitation publicCorrectif disponible

    CVE-2020-5504

    In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

    • Mettez à jour vers 4:4.5.4.1-2ubuntu2.1+esm6
    Publication Mise à jour
  7. CVE-2019-12616

    Moyenne · CVSS 6.5EPSS 20,22%Code d’exploitation publicCorrectif disponible

    CVE-2019-12616

    An issue was discovered in phpMyAdmin before 4.9.0. A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim.

    • Mettez à jour vers 4:4.5.4.1-2ubuntu2.1+esm3
    Publication Mise à jour
  8. CVE-2019-6799

    Moyenne · CVSS 5.9EPSS 14,83%Code d’exploitation publicAucun correctif publié

    CVE-2019-6799

    An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.

    Publication Mise à jour
  9. CVE-2018-19969

    Élevée · CVSS 8.8EPSS 1,06%Aucun correctif publié

    CVE-2018-19969

    phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →