p PatchFirst

ALPINE-CVE-2021-23840

ALPINE-CVE-2021-23840

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

CVSS 7.5 · Hoch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · network

Betroffene Produkte und Versionen

  • openssl Alpine:v3.10

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.11

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.12

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.13

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.14

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl Alpine:v3.9

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl3 Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

  • openssl3 Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.1j-r0

    Auf 1.1.1j-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →