p PatchFirst

ALPINE-CVE-2023-25690

ALPINE-CVE-2023-25690

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Some mod_proxy configurations on Apache HTTP Server versions 2.4.0 through 2.4.55 allow a HTTP Request Smuggling attack. Configurations are affected when mod_proxy is enabled along with some form of RewriteRule or ProxyPassMatch in which a non-specific pattern matches some portion of the user-supplied request-target (URL) data and is then re-inserted into the proxied request-target using variable substitution. For example, something like: RewriteEngine on RewriteRule "^/here/(.*)" "http://example.com:8080/elsewhere?$1"; [P] ProxyPassReverse /here/ http://example.com:8080/ Request splitting/smuggling could result in bypass of access controls in the proxy server, proxying unintended URLs to existing origin servers, and cache poisoning. Users are recommended to update to at least version 2.4.56 of Apache HTTP Server.

CVSS 9.8 · Kritisch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache2 Alpine:v3.14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

  • apache2 Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.56-r0

    Auf 2.4.56-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →