p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in bind

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für bind: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 54

  1. ALPINE-CVE-2023-50868

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2023-50387

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  3. ALPINE-CVE-2023-6516

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-6516

    To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that can be cleaned up is first allocated and then queued for later processing. It was discovered that if the resolver is continuously processing query patterns triggering this type of cache-database maintenance, `named` may not be able to handle the cleanup events in a timely manner. This in turn enables the list of queued cleanup events to grow infinitely large over time, allowing the configured `max-c

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  4. ALPINE-CVE-2023-5680

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2023-5680

    If a resolver cache has a very large number of ECS records stored for the same name, the process of cleaning the cache database node for this name can significantly impair query performance. This issue affects BIND 9 versions 9.11.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  5. ALPINE-CVE-2023-5679

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-5679

    A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.16.12-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  6. ALPINE-CVE-2023-5517

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-5517

    A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative NXDOMAIN response. This issue affects BIND 9 versions 9.12.0 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.16.8-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  7. ALPINE-CVE-2023-4408

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-4408

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by exploiting this flaw. This issue affects both authoritative servers and recursive resolvers. This issue affects BIND 9 versions 9.0.0 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.9.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.

    • Auf 9.16.48-r0 aktualisieren
    Veröffentlicht Aktualisiert
  8. ALPINE-CVE-2023-3341

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-3341

    The code that processes control channel messages sent to `named` calls certain functions recursively during packet parsing. Recursion depth is only limited by the maximum accepted packet size; depending on the environment, this may cause the packet-parsing code to run out of available stack memory, causing `named` to terminate unexpectedly. Since each incoming control channel message is fully parsed before its contents are authenticated, exploiting this flaw does not require the attacker to hold a valid RNDC key; only network access to the control channel's configured TCP port is necessary. This issue affects BIND 9 versions 9.2.0 through 9.1

    • Auf 9.16.44-r0 aktualisieren
    Veröffentlicht Aktualisiert
  9. ALPINE-CVE-2022-3924

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-3924

    This issue can affect BIND 9 resolvers with `stale-answer-enable yes;` that also make use of the option `stale-answer-client-timeout`, configured with a value greater than zero. If the resolver receives many queries that require recursion, there will be a corresponding increase in the number of clients that are waiting for recursion to complete. If there are sufficient clients already waiting when a new client query is received so that it is necessary to SERVFAIL the longest waiting client (see BIND 9 ARM `recursive-clients` limit and soft quota), then it is possible for a race to occur between providing a stale answer to this older client a

    • Auf 9.16.37-r0 aktualisieren
    Veröffentlicht Aktualisiert
  10. ALPINE-CVE-2022-3736

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-3736

    BIND 9 resolver can crash when stale cache and stale answers are enabled, option `stale-answer-client-timeout` is set to a positive integer, and the resolver receives an RRSIG query. This issue affects BIND 9 versions 9.16.12 through 9.16.36, 9.18.0 through 9.18.10, 9.19.0 through 9.19.8, and 9.16.12-S1 through 9.16.36-S1.

    • Auf 9.16.37-r0 aktualisieren
    Veröffentlicht Aktualisiert
  11. ALPINE-CVE-2022-3094

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-3094

    Sending a flood of dynamic DNS updates may cause `named` to allocate large amounts of memory. This, in turn, may cause `named` to exit due to a lack of free memory. We are not aware of any cases where this has been exploited. Memory is allocated prior to the checking of access permissions (ACLs) and is retained during the processing of a dynamic update from a client whose access credentials are accepted. Memory allocated to clients that are not permitted to send updates is released immediately upon rejection. The scope of this vulnerability is limited therefore to trusted clients who are permitted to make dynamic zone changes. If a dynamic

    • Auf 9.16.37-r0 aktualisieren
    Veröffentlicht Aktualisiert
  12. ALPINE-CVE-2022-38178

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-38178

    By spoofing the target resolver with responses that have a malformed EdDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources.

    • Auf 9.16.33-r0 aktualisieren
    Veröffentlicht Aktualisiert
  13. ALPINE-CVE-2022-38177

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-38177

    By spoofing the target resolver with responses that have a malformed ECDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources.

    • Auf 9.16.33-r0 aktualisieren
    Veröffentlicht Aktualisiert
  14. ALPINE-CVE-2022-2906

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-2906

    An attacker can leverage this flaw to gradually erode available memory to the point where named crashes for lack of resources. Upon restart the attacker would have to begin again, but nevertheless there is the potential to deny service.

    • Auf 9.16.33-r0 aktualisieren
    Veröffentlicht Aktualisiert
  15. ALPINE-CVE-2022-2795

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2022-2795

    By flooding the target resolver with queries exploiting this flaw an attacker can significantly impair the resolver's performance, effectively denying legitimate clients access to the DNS resolution service.

    • Auf 9.16.33-r0 aktualisieren
    Veröffentlicht Aktualisiert
  16. ALPINE-CVE-2021-25220

    Mittel · CVSS 6.8Korrektur verfügbar

    ALPINE-CVE-2021-25220

    BIND 9.11.0 -> 9.11.36 9.12.0 -> 9.16.26 9.17.0 -> 9.18.0 BIND Supported Preview Editions: 9.11.4-S1 -> 9.11.36-S1 9.16.8-S1 -> 9.16.26-S1 Versions of BIND 9 earlier than those shown - back to 9.1.0, including Supported Preview Editions - are also believed to be affected but have not been tested as they are EOL. The cache could become poisoned with incorrect records leading to queries being made to the wrong servers, which might also result in false information being returned to clients.

    • Auf 9.16.27-r0 aktualisieren
    Veröffentlicht Aktualisiert
  17. ALPINE-CVE-2022-0396

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2022-0396

    BIND 9.16.11 -> 9.16.26, 9.17.0 -> 9.18.0 and versions 9.16.11-S1 -> 9.16.26-S1 of the BIND Supported Preview Edition. Specifically crafted TCP streams can cause connections to BIND to remain in CLOSE_WAIT status for an indefinite period of time, even after the client has terminated the connection.

    • Auf 9.16.27-r0 aktualisieren
    Veröffentlicht Aktualisiert
  18. ALPINE-CVE-2021-25219

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2021-25219

    In BIND 9.3.0 -> 9.11.35, 9.12.0 -> 9.16.21, and versions 9.9.3-S1 -> 9.11.35-S1 and 9.16.8-S1 -> 9.16.21-S1 of BIND Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.18 of the BIND 9.17 development branch, exploitation of broken authoritative servers using a flaw in response processing can cause degradation in BIND resolver performance. The way the lame cache is currently designed makes it possible for its internal data structures to grow almost infinitely, which may cause significant delays in client query processing.

    • Auf 9.16.22-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →