p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in unbound

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für unbound: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 12

  1. ALPINE-CVE-2024-8508

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2024-8508

    NLnet Labs Unbound up to and including version 1.21.0 contains a vulnerability when handling replies with very large RRsets that it needs to perform name compression for. Malicious upstreams responses with very large RRsets can cause Unbound to spend a considerable time applying name compression to downstream replies. This can lead to degraded performance and eventually denial of service in well orchestrated attacks. The vulnerability can be exploited by a malicious actor querying Unbound for the specially crafted contents of a malicious zone with very large RRsets. Before Unbound replies to the query it will try to apply name compression whi

    • Auf 1.20.0-r1 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2024-33655

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2024-33655

    The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service (resource consumption) by arranging for DNS queries to be accumulated for seconds, such that responses are later sent in a pulsing burst (which can be considered traffic amplification in some cases), aka the "DNSBomb" issue.

    • Auf 1.20.0-r0 aktualisieren
    Veröffentlicht Aktualisiert
  3. ALPINE-CVE-2024-1931

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2024-1931

    NLnet Labs Unbound version 1.18.0 up to and including version 1.19.1 contain a vulnerability that can cause denial of service by a certain code path that can lead to an infinite loop. Unbound 1.18.0 introduced a feature that removes EDE records from responses with size higher than the client's advertised buffer size. Before removing all the EDE records however, it would try to see if trimming the extra text fields on those records would result in an acceptable size while still retaining the EDE codes. Due to an unchecked condition, the code that trims the text of the EDE records could loop indefinitely. This happens when Unbound would reply w

    • Auf 1.19.2-r0 aktualisieren
    Veröffentlicht Aktualisiert
  4. ALPINE-CVE-2023-50868

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 1.19.1-r0 aktualisieren
    Veröffentlicht Aktualisiert
  5. ALPINE-CVE-2023-50387

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 1.19.1-r0 aktualisieren
    Veröffentlicht Aktualisiert
  6. ALPINE-CVE-2022-3204

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-3204

    A vulnerability named 'Non-Responsive Delegation Attack' (NRDelegation Attack) has been discovered in various DNS resolving software. The NRDelegation Attack works by having a malicious delegation with a considerable number of non responsive nameservers. The attack starts by querying a resolver for a record that relies on those unresponsive nameservers. The attack can cause a resolver to spend a lot of time/resources resolving records under a malicious delegation point where a considerable number of unresponsive NS records reside. It can trigger high CPU usage in some resolver implementations that continually look in the cache for resolved NS

    • Auf 1.16.3-r0 aktualisieren
    Veröffentlicht Aktualisiert
  7. ALPINE-CVE-2022-30699

    Mittel · CVSS 6.5Korrektur verfügbar

    ALPINE-CVE-2022-30699

    NLnet Labs Unbound, up to and including version 1.16.1, is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a rogue domain name when the cached delegation information is about to expire. The rogue nameserver delays the response so that the cached delegation information is expired. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries. This action can be repeated when the delegation information is about to expire making the rogue delegation information ever-updating. From version 1.16.2 on

    • Auf 1.16.2-r0 aktualisieren
    Veröffentlicht Aktualisiert
  8. ALPINE-CVE-2022-30698

    Mittel · CVSS 6.5Korrektur verfügbar

    ALPINE-CVE-2022-30698

    NLnet Labs Unbound, up to and including version 1.16.1 is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a subdomain of a rogue domain name. The rogue nameserver returns delegation information for the subdomain that updates Unbound's delegation cache. This action can be repeated before expiry of the delegation information by querying Unbound for a second level subdomain which the rogue nameserver provides new delegation information. Since Unbound is a child-centric resolver, the ever-updating child delegation information can keep a rogue domain na

    • Auf 1.16.2-r0 aktualisieren
    Veröffentlicht Aktualisiert
  9. ALPINE-CVE-2019-18934

    Hoch · CVSS 7.3Korrektur verfügbar

    ALPINE-CVE-2019-18934

    Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code execution after receiving a specially crafted answer. This issue can only be triggered if unbound was compiled with `--enable-ipsecmod` support, and ipsecmod is enabled and used in the configuration.

    • Auf 1.9.5-r0 aktualisieren
    Veröffentlicht Aktualisiert
  10. ALPINE-CVE-2019-16866

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2019-16866

    Unbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a crash via a crafted NOTIFY query. The source IP address of the query must match an access-control rule.

    • Auf 1.9.4-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →