p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in dnsmasq

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für dnsmasq: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 27

  1. ALPINE-CVE-2026-5172

    Hoch · CVSS 7.3Korrektur verfügbar

    ALPINE-CVE-2026-5172

    A buffer overflow in dnsmasq’s extract_addresses() function allows an attacker to trigger a heap out-of-bounds read and crash by exploiting a malformed DNS response, enabling extract_name() to advance the pointer past the record’s end.

    • Auf 2.91-r1 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2026-2291

    Hoch · CVSS 7.3Korrektur verfügbar

    ALPINE-CVE-2026-2291

    dnsmasqs extract_name() function can be abused to cause a heap buffer overflow, allowing an attacker to inject false DNS cache entries, which could result in DNS lookups to redirect to an attacker-controlled IP address, or to cause a DoS.

    • Auf 2.91-r1 aktualisieren
    Veröffentlicht Aktualisiert
  3. ALPINE-CVE-2023-50868

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 2.90-r0 aktualisieren
    Veröffentlicht Aktualisiert
  4. ALPINE-CVE-2023-50387

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 2.90-r0 aktualisieren
    Veröffentlicht Aktualisiert
  5. ALPINE-CVE-2022-0934

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-0934

    A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq. This flaw allows an attacker who sends a crafted packet processed by dnsmasq, potentially causing a denial of service.

    • Auf 2.86-r1 aktualisieren
    Veröffentlicht Aktualisiert
  6. ALPINE-CVE-2021-3448

    Mittel · CVSS 4Korrektur verfügbar

    ALPINE-CVE-2021-3448

    A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for a given network interface, dnsmasq uses a fixed port while forwarding queries. An attacker on the network, able to find the outgoing port used by dnsmasq, only needs to guess the random transmission ID to forge a reply and get it accepted by dnsmasq. This flaw makes a DNS Cache Poisoning attack much easier. The highest threat from this vulnerability is to data integrity.

    • Auf 2.85-r0 aktualisieren
    Veröffentlicht Aktualisiert
  7. ALPINE-CVE-2020-25686

    Niedrig · CVSS 3.7Korrektur verfügbar

    ALPINE-CVE-2020-25686

    A flaw was found in dnsmasq before version 2.83. When receiving a query, dnsmasq does not check for an existing pending request for the same name and forwards a new request. By default, a maximum of 150 pending queries can be sent to upstream servers, so there can be at most 150 queries for the same name. This flaw allows an off-path attacker on the network to substantially reduce the number of attempts that it would have to perform to forge a reply and have it accepted by dnsmasq. This issue is mentioned in the "Birthday Attacks" section of RFC5452. If chained with CVE-2020-25684, the attack complexity of a successful attack is reduced. The

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  8. ALPINE-CVE-2020-25687

    Mittel · CVSS 5.9Korrektur verfügbar

    ALPINE-CVE-2020-25687

    A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in dnsmasq when DNSSEC is enabled and before it validates the received DNS entries. This flaw allows a remote attacker, who can create valid DNS replies, to cause an overflow in a heap-allocated memory. This flaw is caused by the lack of length checks in rfc1035.c:extract_name(), which could be abused to make the code execute memcpy() with a negative size in sort_rrset() and cause a crash in dnsmasq, resulting in a denial of service. The highest threat from this vulnerability is to system availability.

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  9. ALPINE-CVE-2020-25682

    Hoch · CVSS 8.1Korrektur verfügbar

    ALPINE-CVE-2020-25682

    A flaw was found in dnsmasq before 2.83. A buffer overflow vulnerability was discovered in the way dnsmasq extract names from DNS packets before validating them with DNSSEC data. An attacker on the network, who can create valid DNS replies, could use this flaw to cause an overflow with arbitrary data in a heap-allocated memory, possibly executing code on the machine. The flaw is in the rfc1035.c:extract_name() function, which writes data to the memory pointed by name assuming MAXDNAME*2 bytes are available in the buffer. However, in some code execution paths, it is possible extract_name() gets passed an offset from the base buffer, thus reduc

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  10. ALPINE-CVE-2020-25681

    Hoch · CVSS 8.1Korrektur verfügbar

    ALPINE-CVE-2020-25681

    A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in the way RRSets are sorted before validating with DNSSEC data. An attacker on the network, who can forge DNS replies such as that they are accepted as valid, could use this flaw to cause a buffer overflow with arbitrary data in a heap memory segment, possibly executing code on the machine. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  11. ALPINE-CVE-2020-25685

    Niedrig · CVSS 3.7Korrektur verfügbar

    ALPINE-CVE-2020-25685

    A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query, dnsmasq checks in forward.c:reply_query(), which is the forwarded query that matches the reply, by only using a weak hash of the query name. Due to the weak hash (CRC32 when dnsmasq is compiled without DNSSEC, SHA-1 when it is) this flaw allows an off-path attacker to find several different domains all having the same hash, substantially reducing the number of attempts they would have to perform to forge a reply and get it accepted by dnsmasq. This is in contrast with RFC5452, which specifies that the query name is one of the attributes of a query th

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  12. ALPINE-CVE-2020-25684

    Niedrig · CVSS 3.7Korrektur verfügbar

    ALPINE-CVE-2020-25684

    A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query, dnsmasq checks in the forward.c:reply_query() if the reply destination address/port is used by the pending forwarded queries. However, it does not use the address/port to retrieve the exact forwarded query, substantially reducing the number of attempts an attacker on the network would have to perform to forge a reply and get it accepted by dnsmasq. This issue contrasts with RFC5452, which specifies a query's attributes that all must be used to match a reply. This flaw allows an attacker to perform a DNS Cache Poisoning attack. If chained with CVE-202

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  13. ALPINE-CVE-2020-25683

    Mittel · CVSS 5.9Korrektur verfügbar

    ALPINE-CVE-2020-25683

    A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in dnsmasq when DNSSEC is enabled and before it validates the received DNS entries. A remote attacker, who can create valid DNS replies, could use this flaw to cause an overflow in a heap-allocated memory. This flaw is caused by the lack of length checks in rfc1035.c:extract_name(), which could be abused to make the code execute memcpy() with a negative size in get_rdata() and cause a crash in dnsmasq, resulting in a denial of service. The highest threat from this vulnerability is to system availability.

    • Auf 2.83-r0 aktualisieren
    Veröffentlicht Aktualisiert
  14. ALPINE-CVE-2019-14834

    Niedrig · CVSS 3.7Korrektur verfügbar

    ALPINE-CVE-2019-14834

    A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote attackers to cause a denial of service (memory consumption) via vectors involving DHCP response creation.

    • Auf 2.80-r5 aktualisieren
    Veröffentlicht Aktualisiert
  15. ALPINE-CVE-2017-15107

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2017-15107

    A vulnerability was found in the implementation of DNSSEC in Dnsmasq up to and including 2.78. Wildcard synthesized NSEC records could be improperly interpreted to prove the non-existence of hostnames that actually exist.

    • Auf 2.79-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →