p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in nodejs · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für nodejs: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 28

  1. ALPINE-CVE-2018-7160

    Hoch · CVSS 8.8Korrektur verfügbar

    ALPINE-CVE-2018-7160

    The Node.js inspector, in 6.x and later is vulnerable to a DNS rebinding attack which could be exploited to perform remote code execution. An attack is possible from malicious websites open in a web browser on the same computer, or another computer with network access to the computer running the Node.js process. A malicious website could use a DNS rebinding attack to trick the web browser to bypass same-origin-policy checks and to allow HTTP connections to localhost or to hosts on the local network. If a Node.js process with the debug port active is running on localhost or on a host on the local network, the malicious website could connect to

    • Auf 8.11.0-r0 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2018-7159

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2018-7159

    The HTTP parser in all current versions of Node.js ignores spaces in the `Content-Length` header, allowing input such as `Content-Length: 1 2` to be interpreted as having a value of `12`. The HTTP specification does not allow for spaces in the `Content-Length` value and the Node.js HTTP parser has been brought into line on this particular difference. The security risk of this flaw to Node.js users is considered to be VERY LOW as it is difficult, and may be impossible, to craft an attack that makes use of this flaw in a way that could not already be achieved by supplying an incorrect value for `Content-Length`. Vulnerabilities may exist in use

    • Auf 8.11.0-r0 aktualisieren
    Veröffentlicht Aktualisiert
  3. ALPINE-CVE-2018-7158

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2018-7158

    The `'path'` module in the Node.js 4.x release line contains a potential regular expression denial of service (ReDoS) vector. The code in question was replaced in Node.js 6.x and later so this vulnerability only impacts all versions of Node.js 4.x. The regular expression, `splitPathRe`, used within the `'path'` module for the various path parsing functions, including `path.dirname()`, `path.extname()` and `path.parse()` was structured in such a way as to allow an attacker to craft a string, that when passed through one of these functions, could take a significant amount of time to evaluate, potentially leading to a full denial of service.

    • Auf 8.11.0-r0 aktualisieren
    Veröffentlicht Aktualisiert
  4. ALPINE-CVE-2018-1000168

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2018-1000168

    nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

    • Auf 8.11.3-r0 aktualisieren
    Veröffentlicht Aktualisiert
  5. ALPINE-CVE-2017-15897

    Niedrig · CVSS 3.1Korrektur verfügbar

    ALPINE-CVE-2017-15897

    Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100, "This is not correctly encoded", "hex");' The buffer implementation was updated such that the buffer will be initialized to all zeros in these cases.

    • Auf 8.9.3-r0 aktualisieren
    Veröffentlicht Aktualisiert
  6. ALPINE-CVE-2017-15896

    Kritisch · CVSS 9.1Korrektur verfügbar

    ALPINE-CVE-2017-15896

    Node.js was affected by OpenSSL vulnerability CVE-2017-3737 in regards to the use of SSL_read() due to TLS handshake failure. The result was that an active network attacker could send application data to Node.js using the TLS or HTTP2 modules in a way that bypassed TLS authentication and encryption.

    • Auf 8.9.3-r0 aktualisieren
    Veröffentlicht Aktualisiert
  7. ALPINE-CVE-2017-14919

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2017-14919

    Node.js before 4.8.5, 6.x before 6.11.5, and 8.x before 8.8.0 allows remote attackers to cause a denial of service (uncaught exception and crash) by leveraging a change in the zlib module 1.2.9 making 8 an invalid value for the windowBits parameter.

    • Auf 6.11.5-r0 aktualisieren
    Veröffentlicht Aktualisiert
  8. ALPINE-CVE-2017-1000381

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2017-1000381

    The c-ares function `ares_parse_naptr_reply()`, which is used for parsing NAPTR responses, could be triggered to read memory outside of the given input buffer if the passed in DNS response packet was crafted in a particular way.

    • Auf 6.11.1-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →