ALSA-2019:2925
ALSA-2019:2925 · Important: nodejs:10 security update
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages have been upgraded to a later upstream version: nodejs (10.16.3). Security Fix(es): * HTTP/2: large amount of data requests leads to denial of service (CVE-2019-9511) * HTTP/2: flood using PING frames results in unbounded memory growth (CVE-2019-9512) * HTTP/2: flood using PRIORITY frames results in excessive resource consumption (CVE-2019-9513) * HTTP/2: flood using HEADERS frames results in unbounded memory growth (CVE-2019-9514) * HTTP/2: flood using SETTINGS frames results in unbounded memory growth (CVE-2019-9515) * HTTP/2: 0-length headers lead to denial of service (CVE-2019-9516) * HTTP/2: request for large response leads to denial of service (CVE-2019-9517) * HTTP/2: flood using empty frames results in excessive resource consumption (CVE-2019-9518) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
nodejs-nodemon AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.18.3-1.module_el8.3.0+2023+d2377ea3
Auf 1.18.3-1.module_el8.3.0+2023+d2377ea3 aktualisieren
nodejs-nodemon AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.18.3-1.module_el8.3.0+2047+b07ac28e
Auf 1.18.3-1.module_el8.3.0+2047+b07ac28e aktualisieren
nodejs-packaging AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 17-3.module_el8.4.0+2224+b07ac28e
Auf 17-3.module_el8.4.0+2224+b07ac28e aktualisieren
nodejs-packaging AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 17-3.module_el8.4.0+2521+c668cc9f
Auf 17-3.module_el8.4.0+2521+c668cc9f aktualisieren
nodejs-packaging AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 17-3.module_el8.3.0+2023+d2377ea3
Auf 17-3.module_el8.3.0+2023+d2377ea3 aktualisieren
Originalquellen
- https://errata.almalinux.org/8/ALSA-2019-2925.html
- https://vulners.com/cve/CVE-2019-5737
- https://vulners.com/cve/CVE-2019-9511
- https://vulners.com/cve/CVE-2019-9512
- https://vulners.com/cve/CVE-2019-9513
- https://vulners.com/cve/CVE-2019-9514
- https://vulners.com/cve/CVE-2019-9515
- https://vulners.com/cve/CVE-2019-9516
- https://vulners.com/cve/CVE-2019-9517
- https://vulners.com/cve/CVE-2019-9518
- https://osv.dev/vulnerability/ALSA-2019:2925