ALSA-2021:4381
ALSA-2021:4381 · Moderate: GNOME security, bug fix, and enhancement update
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
GNOME is the default desktop environment of AlmaLinux. The following packages have been upgraded to a later upstream version: gdm (40.0), webkit2gtk3 (2.32.3). (BZ#1909300) Security Fix(es): * webkitgtk: Use-after-free in AudioSourceProviderGStreamer leading to arbitrary code execution (CVE-2020-13558) * LibRaw: Stack buffer overflow in LibRaw::identify_process_dng_fields() in identify.cpp (CVE-2020-24870) * webkitgtk: Use-after-free leading to arbitrary code execution (CVE-2020-27918) * webkitgtk: IFrame sandboxing policy violation (CVE-2021-1765) * webkitgtk: Use-after-free leading to arbitrary code execution (CVE-2021-1788) * webkitgtk: Type confusion issue leading to arbitrary code execution (CVE-2021-1789) * webkitgtk: Access to restricted ports on arbitrary servers via port redirection (CVE-2021-1799) * webkitgtk: IFrame sandboxing policy violation (CVE-2021-1801) * webkitgtk: Memory corruption issue leading to arbitrary code execution (CVE-2021-1844) * webkitgtk: Logic issue leading to arbitrary code execution (CVE-2021-1870) * webkitgtk: Logic issue leading to arbitrary code execution (CVE-2021-1871) * webkitgtk: Use-after-free in ImageLoader dispatchPendingErrorEvent leading to information leak and possibly code execution (CVE-2021-21775) * webkitgtk: Use-after-free in WebCore::GraphicsContext leading to information leak and possibly code execution (CVE-2021-21779) * webkitgtk: Use-after-free in fireEventListeners leading to arbitrary code execution (CVE-2021-21806) * webkitgtk: Integer overflow leading to arbitrary code execution (CVE-2021-30663) * webkitgtk: Memory corruption leading to arbitrary code execution (CVE-2021-30665) * webkitgtk: Logic issue leading to leak of sensitive user information (CVE-2021-30682) * webkitgtk: Logic issue leading to universal cross site scripting attack (CVE-2021-30689) * webkitgtk: Logic issue allowing access to restricted ports on arbitrary servers (CVE-2021-30720) * webkitgtk: Memory corruptions leading to arbitrary code execution (CVE-2021-30734) * webkitgtk: Cross-origin issue with iframe elements leading to universal cross site scripting attack (CVE-2021-30744) * webkitgtk: Memory corruptions leading to arbitrary code execution (CVE-2021-30749) * webkitgtk: Type confusion leading to arbitrary code execution (CVE-2021-30758) * webkitgtk: Use-after-free leading to arbitrary code execution (CVE-2021-30795) * webkitgtk: Insufficient checks leading to arbitrary code execution (CVE-2021-30797) * webkitgtk: Memory corruptions leading to arbitrary code execution (CVE-2021-30799) * webkitgtk: User may be unable to fully delete browsing history (CVE-2020-29623) * gnome-autoar: Directory traversal via directory symbolic links pointing outside of the destination directory (CVE-2020-36241) * gnome-autoar: Directory traversal via directory symbolic links pointing outside of the destination directory (incomplete CVE-2020-36241 fix) (CVE-2021-28650) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libraw AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.19.5-3.el8
Auf 0.19.5-3.el8 aktualisieren
libraw-devel AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.19.5-3.el8
Auf 0.19.5-3.el8 aktualisieren
accountsservice AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.55-2.el8
Auf 0.6.55-2.el8 aktualisieren
accountsservice-devel AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.55-2.el8
Auf 0.6.55-2.el8 aktualisieren
accountsservice-libs AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.55-2.el8
Auf 0.6.55-2.el8 aktualisieren
gdm AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:40.0-15.el8
Auf 1:40.0-15.el8 aktualisieren
gnome-autoar AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.3-2.el8
Auf 0.2.3-2.el8 aktualisieren
gnome-calculator AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.2-2.el8
Auf 3.28.2-2.el8 aktualisieren
gnome-classic-session AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.1-20.el8
Auf 3.32.1-20.el8 aktualisieren
gnome-control-center AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.2-28.el8
Auf 3.28.2-28.el8 aktualisieren
gnome-control-center-filesystem AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.2-28.el8
Auf 3.28.2-28.el8 aktualisieren
gnome-online-accounts AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.2-3.el8
Auf 3.28.2-3.el8 aktualisieren
gnome-online-accounts-devel AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.2-3.el8
Auf 3.28.2-3.el8 aktualisieren
gnome-session AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.1-13.el8
Auf 3.28.1-13.el8 aktualisieren
gnome-session-kiosk-session AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.1-13.el8
Auf 3.28.1-13.el8 aktualisieren
gnome-session-wayland-session AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.1-13.el8
Auf 3.28.1-13.el8 aktualisieren
gnome-session-xsession AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.28.1-13.el8
Auf 3.28.1-13.el8 aktualisieren
gnome-settings-daemon AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.0-16.el8.alma
Auf 3.32.0-16.el8.alma aktualisieren
gnome-shell AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.2-40.el8
Auf 3.32.2-40.el8 aktualisieren
gnome-shell-extension-apps-menu AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.1-20.el8
Auf 3.32.1-20.el8 aktualisieren
gnome-shell-extension-auto-move-windows AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.1-20.el8
Auf 3.32.1-20.el8 aktualisieren
gnome-shell-extension-common AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.1-20.el8
Auf 3.32.1-20.el8 aktualisieren
gnome-shell-extension-dash-to-dock AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.1-20.el8
Auf 3.32.1-20.el8 aktualisieren
gnome-shell-extension-desktop-icons AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.32.1-20.el8
Auf 3.32.1-20.el8 aktualisieren
Originalquellen
- https://errata.almalinux.org/8/ALSA-2021-4381.html
- https://vulners.com/cve/CVE-2020-13558
- https://vulners.com/cve/CVE-2020-24870
- https://vulners.com/cve/CVE-2020-27918
- https://vulners.com/cve/CVE-2020-29623
- https://vulners.com/cve/CVE-2020-36241
- https://vulners.com/cve/CVE-2021-1765
- https://vulners.com/cve/CVE-2021-1788
- https://vulners.com/cve/CVE-2021-1789
- https://vulners.com/cve/CVE-2021-1799
- https://vulners.com/cve/CVE-2021-1801
- https://vulners.com/cve/CVE-2021-1844
- https://vulners.com/cve/CVE-2021-1870
- https://vulners.com/cve/CVE-2021-1871
- https://vulners.com/cve/CVE-2021-21775
- https://vulners.com/cve/CVE-2021-21779
- https://vulners.com/cve/CVE-2021-21806
- https://vulners.com/cve/CVE-2021-28650
- https://vulners.com/cve/CVE-2021-30663
- https://vulners.com/cve/CVE-2021-30665
- https://vulners.com/cve/CVE-2021-30682
- https://vulners.com/cve/CVE-2021-30689
- https://vulners.com/cve/CVE-2021-30720
- https://osv.dev/vulnerability/ALSA-2021:4381