ALSA-2023:1743
ALSA-2023:1743 · Important: nodejs:14 security, bug fix, and enhancement update
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages have been upgraded to a later upstream version: nodejs (14.21.3). Security Fix(es): * decode-uri-component: improper input validation resulting in DoS (CVE-2022-38900) * glob-parent: Regular Expression Denial of Service (CVE-2021-35065) * nodejs-minimatch: ReDoS via the braceExpand function (CVE-2022-3517) * c-ares: buffer overflow in config_sortlist() due to missing string length check (CVE-2022-4904) * http-cache-semantics: Regular Expression Denial of Service (ReDoS) vulnerability (CVE-2022-25881) * Node.js: Permissions policies can be bypassed via process.mainModule (CVE-2023-23918) * Node.js: insecure loading of ICU data through ICU_DATA environment variable (CVE-2023-23920) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
nodejs AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:14.21.3-1.module_el8.7.0+3551+53700ee8
Auf 1:14.21.3-1.module_el8.7.0+3551+53700ee8 aktualisieren
nodejs-devel AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:14.21.3-1.module_el8.7.0+3551+53700ee8
Auf 1:14.21.3-1.module_el8.7.0+3551+53700ee8 aktualisieren
nodejs-docs AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:14.21.3-1.module_el8.7.0+3551+53700ee8
Auf 1:14.21.3-1.module_el8.7.0+3551+53700ee8 aktualisieren
nodejs-full-i18n AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:14.21.3-1.module_el8.7.0+3551+53700ee8
Auf 1:14.21.3-1.module_el8.7.0+3551+53700ee8 aktualisieren
nodejs-nodemon AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.20-3.module_el8.7.0+3551+53700ee8
Auf 2.0.20-3.module_el8.7.0+3551+53700ee8 aktualisieren
nodejs-packaging AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 23-3.module_el8.4.0+2522+3bd42762
Auf 23-3.module_el8.4.0+2522+3bd42762 aktualisieren
npm AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:6.14.18-1.14.21.3.1.module_el8.7.0+3551+53700ee8
Auf 1:6.14.18-1.14.21.3.1.module_el8.7.0+3551+53700ee8 aktualisieren
Originalquellen
- https://access.redhat.com/errata/RHSA-2023:1743
- https://access.redhat.com/security/cve/CVE-2021-35065
- https://access.redhat.com/security/cve/CVE-2022-25881
- https://access.redhat.com/security/cve/CVE-2022-3517
- https://access.redhat.com/security/cve/CVE-2022-38900
- https://access.redhat.com/security/cve/CVE-2022-4904
- https://access.redhat.com/security/cve/CVE-2023-23918
- https://access.redhat.com/security/cve/CVE-2023-23920
- https://bugzilla.redhat.com/2134609
- https://bugzilla.redhat.com/2156324
- https://bugzilla.redhat.com/2165824
- https://bugzilla.redhat.com/2168631
- https://bugzilla.redhat.com/2170644
- https://bugzilla.redhat.com/2171935
- https://bugzilla.redhat.com/2172217
- https://bugzilla.redhat.com/2175826
- https://errata.almalinux.org/8/ALSA-2023-1743.html
- https://osv.dev/vulnerability/ALSA-2023:1743