p PatchFirst

ALSA-2023:2654

ALSA-2023:2654 · Moderate: nodejs:18 security, bug fix, and enhancement update

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages have been upgraded to a later upstream version: nodejs (18.14.2). Security Fix(es): * glob-parent: Regular Expression Denial of Service (CVE-2021-35065) * c-ares: buffer overflow in config_sortlist() due to missing string length check (CVE-2022-4904) * http-cache-semantics: Regular Expression Denial of Service (ReDoS) vulnerability (CVE-2022-25881) * Node.js: Permissions policies can be bypassed via process.mainModule (CVE-2023-23918) * Node.js: OpenSSL error handling issues in nodejs crypto library (CVE-2023-23919) * Node.js: Fetch API did not protect against CRLF injection in host headers (CVE-2023-23936) * Node.js: insecure loading of ICU data through ICU_DATA environment variable (CVE-2023-23920) * Node.js: Regular Expression Denial of Service in Headers fetch API (CVE-2023-24807) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • nodejs AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:18.14.2-2.module_el9.2.0+29+de583a0b

    Auf 1:18.14.2-2.module_el9.2.0+29+de583a0b aktualisieren

  • nodejs-devel AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:18.14.2-2.module_el9.2.0+29+de583a0b

    Auf 1:18.14.2-2.module_el9.2.0+29+de583a0b aktualisieren

  • nodejs-docs AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:18.14.2-2.module_el9.2.0+29+de583a0b

    Auf 1:18.14.2-2.module_el9.2.0+29+de583a0b aktualisieren

  • nodejs-full-i18n AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:18.14.2-2.module_el9.2.0+29+de583a0b

    Auf 1:18.14.2-2.module_el9.2.0+29+de583a0b aktualisieren

  • nodejs-nodemon AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.20-2.module_el9.2.0+29+de583a0b

    Auf 2.0.20-2.module_el9.2.0+29+de583a0b aktualisieren

  • nodejs-packaging AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2021.06-4.module_el9.1.0+13+d9a595ea

    Auf 2021.06-4.module_el9.1.0+13+d9a595ea aktualisieren

  • nodejs-packaging-bundler AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2021.06-4.module_el9.1.0+13+d9a595ea

    Auf 2021.06-4.module_el9.1.0+13+d9a595ea aktualisieren

  • npm AlmaLinux:9

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:9.5.0-1.18.14.2.2.module_el9.2.0+29+de583a0b

    Auf 1:9.5.0-1.18.14.2.2.module_el9.2.0+29+de583a0b aktualisieren

Originalquellen

Prüfen Sie Ihren Server →