ALSA-2023:4645
ALSA-2023:4645 · Important: .NET 6.0 security, bug fix, and enhancement update
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 6.0.121 and .NET Runtime 6.0.21. Security Fix(es): * dotnet: RCE under dotnet commands (CVE-2023-35390) * dotnet: Kestrel vulnerability to slow read attacks leading to Denial of Service attack (CVE-2023-38180) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
aspnetcore-runtime-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.21-1.el8_8
Auf 6.0.21-1.el8_8 aktualisieren
aspnetcore-targeting-pack-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.21-1.el8_8
Auf 6.0.21-1.el8_8 aktualisieren
dotnet-apphost-pack-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.21-1.el8_8
Auf 6.0.21-1.el8_8 aktualisieren
dotnet-hostfxr-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.21-1.el8_8
Auf 6.0.21-1.el8_8 aktualisieren
dotnet-runtime-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.21-1.el8_8
Auf 6.0.21-1.el8_8 aktualisieren
dotnet-sdk-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.121-1.el8_8
Auf 6.0.121-1.el8_8 aktualisieren
dotnet-sdk-6.0-source-built-artifacts AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.121-1.el8_8
Auf 6.0.121-1.el8_8 aktualisieren
dotnet-targeting-pack-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.21-1.el8_8
Auf 6.0.21-1.el8_8 aktualisieren
dotnet-templates-6.0 AlmaLinux:8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.121-1.el8_8
Auf 6.0.121-1.el8_8 aktualisieren
Originalquellen
- https://access.redhat.com/errata/RHSA-2023:4645
- https://access.redhat.com/security/cve/CVE-2023-35390
- https://access.redhat.com/security/cve/CVE-2023-38180
- https://bugzilla.redhat.com/2228621
- https://bugzilla.redhat.com/2228622
- https://errata.almalinux.org/8/ALSA-2023-4645.html
- https://osv.dev/vulnerability/ALSA-2023:4645