p PatchFirst

CVE-2014-5244

CVE-2014-5244 · Symfony vulnerable to denial of service via a malicious HTTP Host header

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, and 2.5.X versions of the Symfony HttpFoundation component are affected by this security issue. This issue has been fixed in Symfony 2.3.19, 2.4.9, and 2.5.4. Note that no fixes are provided for Symfony 2.0, 2.1, and 2.2 as they are not maintained anymore. Description When an arbitrarily long hostname is sent by a client, its parsing in `Request::getHost()` can lead to a DoS attack, due to the way we validate the hostname via a regular expression. Resolution The regular expression used to parse and validate the hostname from the HTTP request has been modified to avoid too much sensitivity to the submitted value length. The patch for this issue is available here: https://github.com/symfony/symfony/pull/11828

CVSS 7.5 · Hoch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • symfony/http-foundation Packagist

    Softwareversionen
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • v2.0.10
    • v2.0.12
    • v2.0.13
    • v2.0.14
    • v2.0.15
    • v2.0.16
    • v2.0.17
    • v2.0.18
    • v2.0.19
    • v2.0.20
    • v2.0.21
    • v2.0.22
    • v2.0.23
    • v2.0.24
    • v2.0.25
    • v2.0.9
    • v2.1.0
    • v2.1.1
    • v2.1.10
    • v2.1.11
    • v2.1.12
    • v2.1.13
    • v2.1.2
    • v2.1.3
    • v2.1.4
    • v2.1.5
    • v2.1.6
    • v2.1.7
    • v2.1.8
    • v2.1.9
    • v2.2.0
    • v2.2.1
    • v2.2.10
    • v2.2.11
    • v2.2.2
    • v2.2.3
    • v2.2.4
    • v2.2.5
    • v2.2.6
    • v2.2.7
    • v2.2.8
    • v2.2.9
    • v2.3.0
    • v2.3.1
    • v2.3.10
    • v2.3.11
    • v2.3.12
    • v2.3.13
    • v2.3.14
    • v2.3.15
    • v2.3.16
    • v2.3.17
    • v2.3.18
    • v2.3.2
    • v2.3.3
    • v2.3.4
    • v2.3.5
    • v2.3.6
    • v2.3.7
    • v2.3.8
    • v2.3.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0, < 2.3.19

    Auf 2.3.19 aktualisieren

  • symfony/http-foundation Packagist

    Softwareversionen
    • v2.4.0
    • v2.4.1
    • v2.4.2
    • v2.4.3
    • v2.4.4
    • v2.4.5
    • v2.4.6
    • v2.4.7
    • v2.4.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.9

    Auf 2.4.9 aktualisieren

  • symfony/http-foundation Packagist

    Softwareversionen
    • v2.5.0
    • v2.5.1
    • v2.5.2
    • v2.5.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.4

    Auf 2.5.4 aktualisieren

  • symfony/symfony Packagist

    Softwareversionen
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • v2.0.10
    • v2.0.11
    • v2.0.12
    • v2.0.13
    • v2.0.14
    • v2.0.15
    • v2.0.16
    • v2.0.17
    • v2.0.18
    • v2.0.19
    • v2.0.20
    • v2.0.21
    • v2.0.22
    • v2.0.23
    • v2.0.24
    • v2.0.25
    • v2.0.9
    • v2.1.0
    • v2.1.0-BETA1
    • v2.1.0-BETA2
    • v2.1.0-BETA3
    • v2.1.0-BETA4
    • v2.1.0-RC1
    • v2.1.0-RC2
    • v2.1.1
    • v2.1.10
    • v2.1.11
    • v2.1.12
    • v2.1.13
    • v2.1.2
    • v2.1.3
    • v2.1.4
    • v2.1.5
    • v2.1.6
    • v2.1.7
    • v2.1.8
    • v2.1.9
    • v2.2.0
    • v2.2.0-BETA1
    • v2.2.0-BETA2
    • v2.2.0-RC1
    • v2.2.0-RC2
    • v2.2.0-RC3
    • v2.2.1
    • v2.2.10
    • v2.2.11
    • v2.2.2
    • v2.2.3
    • v2.2.4
    • v2.2.5
    • v2.2.6
    • v2.2.7
    • v2.2.8
    • v2.2.9
    • v2.3.0
    • v2.3.0-BETA1
    • v2.3.0-BETA2
    • v2.3.0-RC1
    • v2.3.1
    • v2.3.10
    • v2.3.11
    • v2.3.12
    • v2.3.13
    • v2.3.14
    • v2.3.15
    • v2.3.16
    • v2.3.17
    • v2.3.18
    • v2.3.2
    • v2.3.3
    • v2.3.4
    • v2.3.5
    • v2.3.6
    • v2.3.7
    • v2.3.8
    • v2.3.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0, < 2.3.19

    Auf 2.3.19 aktualisieren

  • symfony/symfony Packagist

    Softwareversionen
    • v2.4.0
    • v2.4.1
    • v2.4.2
    • v2.4.3
    • v2.4.4
    • v2.4.5
    • v2.4.6
    • v2.4.7
    • v2.4.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.9

    Auf 2.4.9 aktualisieren

  • symfony/symfony Packagist

    Softwareversionen
    • v2.5.0
    • v2.5.1
    • v2.5.2
    • v2.5.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.4

    Auf 2.5.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →