CVE-2015-2309
CVE-2015-2309 · Symfony has unsafe methods in the Request class
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, 2.5.X, and 2.6.X versions of the Symfony HttpFoundation component are affected by this security issue. This issue has been fixed in Symfony 2.3.27, 2.5.11, and 2.6.6. Note that no fixes are provided for Symfony 2.0, 2.1, 2.2, and 2.4 as they are not maintained anymore. ### Description The Symfony\Component\HttpFoundation\Request class provides a mechanism that ensures it does not trust HTTP header values coming from a "non-trusted" client. Unfortunately, it assumes that the remote address is always a trusted client if at least one trusted proxy is involved in the request; this allows a man-in-the-middle attack between the latest trusted proxy and the web server. The following methods are impacted: getPort(), isSecure(), and getHost(), and getClientIps(). ### Resolution All impacted methods now check that the remote address is trusted, which fixes the issue. The patch for this issue is available [here](https://github.com/symfony/symfony/pull/14166).
CVSS 5.3 · Mittel · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
symfony Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.21+dfsg-4
Auf 2.3.21+dfsg-4 aktualisieren
symfony Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.21+dfsg-4
Auf 2.3.21+dfsg-4 aktualisieren
symfony Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.21+dfsg-4
Auf 2.3.21+dfsg-4 aktualisieren
symfony/http-foundation Packagist
- Softwareversionen
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- v2.0.10
- v2.0.12
- v2.0.13
- v2.0.14
- v2.0.15
- v2.0.16
- v2.0.17
- v2.0.18
- v2.0.19
- v2.0.20
- v2.0.21
- v2.0.22
- v2.0.23
- v2.0.24
- v2.0.25
- v2.0.9
- v2.1.0
- v2.1.1
- v2.1.10
- v2.1.11
- v2.1.12
- v2.1.13
- v2.1.2
- v2.1.3
- v2.1.4
- v2.1.5
- v2.1.6
- v2.1.7
- v2.1.8
- v2.1.9
- v2.2.0
- v2.2.1
- v2.2.10
- v2.2.11
- v2.2.2
- v2.2.3
- v2.2.4
- v2.2.5
- v2.2.6
- v2.2.7
- v2.2.8
- v2.2.9
- v2.3.0
- v2.3.1
- v2.3.10
- v2.3.11
- v2.3.12
- v2.3.13
- v2.3.14
- v2.3.15
- v2.3.16
- v2.3.17
- v2.3.18
- v2.3.19
- v2.3.2
- v2.3.20
- v2.3.21
- v2.3.22
- v2.3.23
- v2.3.24
- v2.3.25
- v2.3.26
- v2.3.3
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.3.27
Auf 2.3.27 aktualisieren
symfony/http-foundation Packagist
- Softwareversionen
- v2.4.0
- v2.4.1
- v2.4.10
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.4.9
- v2.5.0
- v2.5.0-BETA1
- v2.5.0-BETA2
- v2.5.0-RC1
- v2.5.1
- v2.5.10
- v2.5.2
- v2.5.3
- v2.5.4
- v2.5.5
- v2.5.6
- v2.5.7
- v2.5.8
- v2.5.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0, < 2.5.11
Auf 2.5.11 aktualisieren
symfony/http-foundation Packagist
- Softwareversionen
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.6.0, < 2.6.6
Auf 2.6.6 aktualisieren
symfony/symfony Packagist
- Softwareversionen
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- v2.0.10
- v2.0.11
- v2.0.12
- v2.0.13
- v2.0.14
- v2.0.15
- v2.0.16
- v2.0.17
- v2.0.18
- v2.0.19
- v2.0.20
- v2.0.21
- v2.0.22
- v2.0.23
- v2.0.24
- v2.0.25
- v2.0.9
- v2.1.0
- v2.1.0-BETA1
- v2.1.0-BETA2
- v2.1.0-BETA3
- v2.1.0-BETA4
- v2.1.0-RC1
- v2.1.0-RC2
- v2.1.1
- v2.1.10
- v2.1.11
- v2.1.12
- v2.1.13
- v2.1.2
- v2.1.3
- v2.1.4
- v2.1.5
- v2.1.6
- v2.1.7
- v2.1.8
- v2.1.9
- v2.2.0
- v2.2.0-BETA1
- v2.2.0-BETA2
- v2.2.0-RC1
- v2.2.0-RC2
- v2.2.0-RC3
- v2.2.1
- v2.2.10
- v2.2.11
- v2.2.2
- v2.2.3
- v2.2.4
- v2.2.5
- v2.2.6
- v2.2.7
- v2.2.8
- v2.2.9
- v2.3.0
- v2.3.0-BETA1
- v2.3.0-BETA2
- v2.3.0-RC1
- v2.3.1
- v2.3.10
- v2.3.11
- v2.3.12
- v2.3.13
- v2.3.14
- v2.3.15
- v2.3.16
- v2.3.17
- v2.3.18
- v2.3.19
- v2.3.2
- v2.3.20
- v2.3.21
- v2.3.22
- v2.3.23
- v2.3.24
- v2.3.25
- v2.3.26
- v2.3.3
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.3.27
Auf 2.3.27 aktualisieren
symfony/symfony Packagist
- Softwareversionen
- v2.4.0
- v2.4.1
- v2.4.10
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.4.9
- v2.5.0
- v2.5.0-BETA1
- v2.5.0-BETA2
- v2.5.0-RC1
- v2.5.1
- v2.5.10
- v2.5.2
- v2.5.3
- v2.5.4
- v2.5.5
- v2.5.6
- v2.5.7
- v2.5.8
- v2.5.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0, < 2.5.11
Auf 2.5.11 aktualisieren
symfony/symfony Packagist
- Softwareversionen
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.6.0, < 2.6.6
Auf 2.6.6 aktualisieren
Originalquellen
- https://github.com/symfony/symfony/pull/14166
- https://github.com/symfony/symfony/commit/6c73f0ce9302a0091bbfbb96f317e400ce16ef84
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-foundation/CVE-2015-2309.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2015-2309.yaml
- https://symfony.com/cve-2015-2309
- https://osv.dev/vulnerability/GHSA-p684-f7fh-jv2j