p PatchFirst

CVE-2017-3737

CVE-2017-3737

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenSSL 1.0.2 (starting from version 1.0.2b) introduced an "error state" mechanism. The intent was that if a fatal error occurred during a handshake then OpenSSL would move into the error state and would immediately fail if you attempted to continue the handshake. This works as designed for the explicit handshake functions (SSL_do_handshake(), SSL_accept() and SSL_connect()), however due to a bug it does not work correctly if SSL_read() or SSL_write() is called directly. In that scenario, if the handshake fails then a fatal error will be returned in the initial function call. If SSL_read()/SSL_write() is subsequently called by the application for the same SSL object then it will succeed and the data is passed without being decrypted/encrypted directly from the SSL/TLS record layer. In order to exploit this issue an application bug would have to be present that resulted in a call to SSL_read()/SSL_write() being issued after having already received a fatal error. OpenSSL version 1.0.2b-1.0.2m are affected. Fixed in OpenSSL 1.0.2n. OpenSSL 1.1.0 is not affected.

CVSS 5.9 · Mittel · EPSS 78,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · network

Betroffene Produkte und Versionen

  • openssl

    Softwareversionen
    • 1.0.2b-1.0.2m: Betroffen

    Keine Korrektur veröffentlicht

  • openssl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.0b-2

    Auf 1.1.0b-2 aktualisieren

  • openssl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.0b-2

    Auf 1.1.0b-2 aktualisieren

  • openssl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.0b-2

    Auf 1.1.0b-2 aktualisieren

  • openssl Ubuntu:16.04:LTS

    Softwareversionen
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.10

    Auf 1.0.2g-1ubuntu4.10 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →