p PatchFirst

CVE-2018-1000075

CVE-2018-1000075

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

CVSS 7.5 · Hoch · EPSS 4,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • jruby Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.17.0-1

    Auf 9.1.17.0-1 aktualisieren

  • jruby Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.17.0-1

    Auf 9.1.17.0-1 aktualisieren

  • jruby Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.17.0-1

    Auf 9.1.17.0-1 aktualisieren

  • rubygems Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Auf 3.2.0~rc.1-1 aktualisieren

  • rubygems Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Auf 3.2.0~rc.1-1 aktualisieren

  • rubygems Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Auf 3.2.0~rc.1-1 aktualisieren

  • ruby1.9.1 Ubuntu:14.04:LTS

    Softwareversionen
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    • 1.9.3.448-1ubuntu2
    • 1.9.3.484-1ubuntu1
    • 1.9.3.484-1ubuntu2
    • 1.9.3.484-2ubuntu1
    • 1.9.3.484-2ubuntu1.1
    • 1.9.3.484-2ubuntu1.2
    • 1.9.3.484-2ubuntu1.3
    • 1.9.3.484-2ubuntu1.5
    • 1.9.3.484-2ubuntu1.6
    • 1.9.3.484-2ubuntu1.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.9.3.484-2ubuntu1.8

    Auf 1.9.3.484-2ubuntu1.8 aktualisieren

  • ruby2.0 Ubuntu:14.04:LTS

    Softwareversionen
    • 2.0.0.299-2
    • 2.0.0.343-1
    • 2.0.0.343-1ubuntu1
    • 2.0.0.353-1
    • 2.0.0.353-1ubuntu1
    • 2.0.0.484-1ubuntu1
    • 2.0.0.484-1ubuntu2
    • 2.0.0.484-1ubuntu2.1
    • 2.0.0.484-1ubuntu2.2
    • 2.0.0.484-1ubuntu2.4
    • 2.0.0.484-1ubuntu2.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.0.484-1ubuntu2.6

    Auf 2.0.0.484-1ubuntu2.6 aktualisieren

  • jruby Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.5.6-5ubuntu1
    • 1.5.6-6
    • 1.5.6-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.6-9+deb8u2build0.14.04.1~esm2

    Auf 1.5.6-9+deb8u2build0.14.04.1~esm2 aktualisieren

  • ruby2.3 Ubuntu:16.04:LTS

    Softwareversionen
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.3.1-2~16.04.7

    Auf 2.3.1-2~16.04.7 aktualisieren

  • jruby Ubuntu:16.04:LTS

    Softwareversionen
    • 1.7.21-2ubuntu4
    • 1.7.22-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Ubuntu:18.04:LTS

    Softwareversionen
    • 9.1.13.0-1
    • 9.1.17.0-1~18.04
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →