p PatchFirst

CVE-2018-1000136

CVE-2018-1000136

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Electron version 1.7 up to 1.7.12; 1.8 up to 1.8.3 and 2.0.0 up to 2.0.0-beta.3 contains an improper handling of values vulnerability in Webviews that can result in remote code execution. This attack appear to be exploitable via an app which allows execution of 3rd party code AND disallows node integration AND has not specified if webview is enabled/disabled. This vulnerability appears to have been fixed in 1.7.13, 1.8.4, 2.0.0-beta.4.

CVSS 8.1 · Hoch · EPSS 5,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.7.0, < 1.7.13

    Auf 1.7.13 aktualisieren

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.8.0, < 1.8.4

    Auf 1.8.4 aktualisieren

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0-beta.1, < 2.0.0-beta.5

    Auf 2.0.0-beta.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →